Bug 815730 - RPM does not include a /etc/sysconfig/sanlock file
RPM does not include a /etc/sysconfig/sanlock file
Status: CLOSED DUPLICATE of bug 782600
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Teigland
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 07:39 EDT by Daniel Berrange
Modified: 2016-04-18 02:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 12:53:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-04-24 07:39:14 EDT
Description of problem:
The sanlock init script allows use of a /etc/sysconfig/sanlock file to customize startup options. The RPM does not, however, include any such file. It should be installed, showing example config options that can be used, but commented out.

Version-Release number of selected component (if applicable):
sanlock-1.8-2.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install sanlock
2. cat /etc/sysconfig/sanlock
3.
  
Actual results:
No such file

Expected results:
# Add any command line options for the sanlock daemon
# For example, to disable use of the watchdog use '-w 0'
#SANLOCK_OPTS="-w 0"


Additional info:
Comment 2 Daniel Berrange 2012-04-24 08:48:29 EDT
> #SANLOCK_OPTS="-w 0"

Hah, I even typod in my example - which just goes to demonstrate the value of having an example. The env var name should of course be "SANLOCKOPTS"
Comment 3 David Teigland 2012-04-24 12:03:42 EDT
Thanks Dan, I pushed out a sample, and will include it in the next build.
I include the "-w 0" example, but refer people to the sanlock man page
for the full list of command line options.
Comment 4 RHEL Product and Program Management 2012-05-03 01:14:10 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 David Teigland 2012-05-03 12:53:45 EDT
This will be fixed in the final 6.3 sanlock rebase.

*** This bug has been marked as a duplicate of bug 782600 ***

Note You need to log in before you can comment on or make changes to this bug.