Bug 815744 - jbpm-human-task.war doesn't contain some jars though they are not provided by every supported container (EWS)
jbpm-human-task.war doesn't contain some jars though they are not provided by...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Build Process (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity medium
: ER8
: BRMS 5.3.0.GA
Assigned To: lcarlon
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 08:19 EDT by Petr Široký
Modified: 2012-06-24 22:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 22:59:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Široký 2012-04-24 08:19:57 EDT
Description of problem:
jbpm-human-task.war doesn't contain several jars that are not provided by every
supported container (like EWS). 
Following jars are missing:
 - persitentce-api-1.0.jar
 - dom4j*.jar
 - javassist*.jar
 - hibernate*.jars (core, entity-manager, annotations, common-annotations)


Steps to Reproduce:
1. Deploy jbpm-human-task.war to EWS.
2. Start EWS
3. NoClassDefFoundError will be thrown

The jars should be either included in lib dir of the jbpm-human-task.war (which may not be possible) or the documentation must specify what jars (and from) should
be copied to lib dir when deploying to EWS.
Comment 1 Lukáš Petrovický 2012-04-24 08:26:23 EDT
Necessary for supporting EWS, requesting blocker.
Comment 2 Kris Verlaenen 2012-05-09 12:36:40 EDT
Will this be resolved by documenting this or by fixing this on the product side?  Or do you need support from the engineering team to modify this in the product branch / at the community side as well?  If so, could you recommend what needs to be done exactly?
Comment 3 Ryan Zhang 2012-05-10 08:05:35 EDT
I think we had better to specify how to add those jars in documentations.

Notice that by adding those jars would cause persistence error when deploy them to EAP based container.
 
And plus, it seems to me that it can't be deployable out of box without providing a detail steps how to configure the jbpm-human-task.war, business-central.war and gwt-console-server etcs when deploying them to EWS. That at least includes how to configure datasource and adding some support jars.
Comment 4 Lukáš Petrovický 2012-05-10 08:16:52 EDT
(In reply to comment #3)
> I think we had better to specify how to add those jars in documentations.

This is the same solution we've historically used for Guvnor. I think we could do it in this case as well - Lee?
Comment 5 lcarlon 2012-05-10 20:35:44 EDT
Hi Lukas,

I'm updating the instructions now. I'll post a link as soon as the updated instructions are online.

Thanks
Comment 9 Ryan Zhang 2012-05-14 04:16:48 EDT
The fixed for this issue should be included in ER7. Please do verification on it.
Comment 10 Petr Široký 2012-05-14 10:39:38 EDT
The jbpm-human-task.war also needs slf4* and log4j* jars. As these jars are needed by all deployed wars, I suggest to copy them into tomcat's lib dir and not to have them in every WEB-INF/lib dir. For tomcat5 the lib dir is tomcat5/shared/lib and for tomcat6 its tomcat6/lib.

I just figured out that jbpm-human-task.war does not need persitence-api-1.0.jar, because jbmp-engine/lib dir contains also hibernate-jpa*.jar which contains same classes and it is definitely better co have that jar on classpath. This jar gets copied with other hibernate jars, so no need for extra copy.
Comment 12 Ryan Zhang 2012-05-25 05:07:54 EDT
Please verify them on ER8.
Comment 14 lcarlon 2012-06-24 22:59:05 EDT
Closing as status already set to verified.

Note You need to log in before you can comment on or make changes to this bug.