Bug 815748 - Network time can't be enabled
Network time can't be enabled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker 816493 816495
  Show dependency treegraph
 
Reported: 2012-04-24 08:29 EDT by Kamil Páral
Modified: 2012-05-02 14:17 EDT (History)
17 users (show)

See Also:
Fixed In Version: systemd-44-7.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 816493 816495 (view as bug list)
Environment:
Last Closed: 2012-05-02 00:53:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-04-24 08:29:19 EDT
Description of problem:
Clean installation of F17 Beta i686 Live into VM. I open Date and Time configuration and slide "Network Time" to ON. When I check in terminal, chronyd.service is disabled and stopped.

I reboot. chronyd.service is obviously still disabled and stopped. When I open Date and Time configuration, "Network Time" is set to OFF.

Version-Release number of selected component (if applicable):
control-center-3.4.0-1.fc17.i686
chrony-1.27-0.1.pre1.fc17.i686

How reproducible:
on VM and on bare-metal

Expected results:
chronyd.service is enabled and running, time is synchronized, and date and time configuration shows that network time is enabled.
Comment 1 Kamil Páral 2012-04-24 08:32:23 EDT
Proposing as F17 blocker:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in common use"
https://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria
Comment 2 Kamil Páral 2012-04-24 09:24:59 EDT
Please note that when I select "Synchronize time over the network" in firstboot, it enables and starts chronyd.service correctly, but Date and Time configuration still shows "Network Time" as OFF. It is probably related issue. If it is not, I'll report it separately, let me know.
Comment 4 Lennart Poettering 2012-04-25 10:56:26 EDT
systemd upstream will now activate/enable systemd-timedated-ntp.target instead of ntpd.service or chrony.service. These two packages should then hook into the target to get started indirectly.

http://cgit.freedesktop.org/systemd/systemd/commit/?id=e2875c46936a16efc0f58f9e6e2570cdda8d6d98

What's left to do: 

- get this into Fedora
- updte chrony and ntpd to include the necessary .wants/ symlink and BindTo directive
Comment 5 Matthias Clasen 2012-04-25 12:03:00 EDT
Can you provide chrony/ntpd patches and file bugs ?
Comment 6 Fedora Update System 2012-04-25 20:31:35 EDT
systemd-44-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/systemd-44-7.fc17
Comment 7 Michal Schmidt 2012-04-26 05:18:46 EDT
(In reply to comment #4)
> What's left to do: 
> 
> - get this into Fedora

systemd-44-7.fc17 has it.

> - updte chrony and ntpd to include the necessary .wants/ symlink and BindTo
> directive

By the necessary .wants/ symlink you mean:

/usr/lib/systemd/system/systemd-timedated-ntp.target.wants/chronyd.service -> ../chronyd.service

(i.e. ship it in the package. Not create it using the [Install] section)

The BindTo directive will go into chronyd.service's [Unit] section and say:
BindTo=systemd-timedated-ntp.target

Going to clone this bug for chrony and ntpd now.
Comment 8 Fedora Update System 2012-04-26 15:28:07 EDT
Package systemd-44-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-44-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6671/systemd-44-7.fc17
then log in and leave karma (feedback).
Comment 9 Timothy Davis 2012-05-01 14:45:09 EDT
update works
F17-TC2
Comment 10 Chris Murphy 2012-05-01 14:45:42 EDT
DVD TC2 install, enabled time sync during first boot. chronyd is running, and systemd reports active status, persistent through reboot. Appears to be fixed.
Comment 11 Tim Flink 2012-05-01 17:45:35 EDT
Discussed in the 2012-05-01 blocker bug review meeting. This doesn't clearly hit any release criteria and it sounds like it could be fixed with an update.

Please re-test with a new F17 install using final TC2 or newer and see if this has indeed been fixed.
Comment 12 Fedora Update System 2012-05-02 00:53:56 EDT
systemd-44-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Kamil Páral 2012-05-02 06:49:46 EDT
Fix confirmed.
Comment 14 akshay vyas 2012-05-02 14:17:09 EDT
you have to install ntp daemon its in fedora update-testing

1.yum install ntp*

2. reboot

3. service ntpd start/restart or systemctl start ntpd.service

4. enable ntpd systemctl enable ntp.service

after that when i logged in again i checked the status wit systemctl status ntpd.service


here's the output

[root@localhost liveuser]# systemctl status ntpd.service
ntpd.service - Network Time Service
	  Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled)
	  Active: active (running) since Thu, 03 May 2012 04:56:57 +0530
	Main PID: 2030 (ntpd)
	  CGroup: name=systemd:/system/ntpd.service
		  └ 2030 /usr/sbin/ntpd -u ntp:ntp -g

May 03 04:56:57 localhost.localdomain ntpd[2030]: peers refreshed
May 03 04:56:57 localhost.localdomain ntpd[2030]: Listening on routing socket...
May 03 04:56:58 localhost.localdomain ntpd[2030]: 0.0.0.0 c016 06 restart
May 03 04:56:58 localhost.localdomain ntpd[2030]: 0.0.0.0 c012 02 freq_set ke...
May 03 04:56:58 localhost.localdomain ntpd[2030]: 0.0.0.0 c011 01 freq_not_set
May 03 04:57:04 localhost.localdomain ntpd[2030]: 0.0.0.0 c61c 0c clock_step ...
May 02 23:27:04 localhost.localdomain ntpd[2030]: 0.0.0.0 c614 04 freq_mode
May 02 23:27:05 localhost.localdomain ntpd[2030]: 0.0.0.0 c618 08 no_sys_peer
May 02 23:42:17 localhost.localdomain ntpd[2030]: 0.0.0.0 c612 02 freq_set ke...
May 02 23:42:17 localhost.localdomain ntpd[2030]: 0.0.0.0 c615 05 clock_sync
[root@localhost liveuser]#

Note You need to log in before you can comment on or make changes to this bug.