This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 815793 - AttributeError: 'NoneType' object has no attribute 'getSize'
AttributeError: 'NoneType' object has no attribute 'getSize'
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:fbb6f1f0598335302...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 10:23 EDT by CoffeeAndKeyboard
Modified: 2012-06-09 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-09 18:48:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (3.47 MB, text/plain)
2012-04-24 10:23 EDT, CoffeeAndKeyboard
no flags Details

  None (edit)
Description CoffeeAndKeyboard 2012-04-24 10:23:03 EDT
The following was filed automatically by anaconda:
anaconda 15.31 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 1433, in _postCreate
    self._currentSize = self.partedPartition.getSize()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 751, in create
    self._postCreate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 240, in execute
    self.device.create(intf=intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 313, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 116, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1257, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'getSize'
Comment 1 CoffeeAndKeyboard 2012-04-24 10:23:19 EDT
Created attachment 579872 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2012-05-23 10:25:28 EDT
Please test again with F17 and let us know if this is still a problem for you.  Thanks.
Comment 3 CoffeeAndKeyboard 2012-06-09 18:48:43 EDT
Tried out with the F17 x86_64 release and did not encounter this issue. I suppose this may have been resolved alongwith other changes since F15. 

I am closing this bug. It may be reopened if this issue continues to crop up. Thanks.

Note You need to log in before you can comment on or make changes to this bug.