Bug 815805 - systemd or mysql littering /tmp
systemd or mysql littering /tmp
Status: CLOSED DUPLICATE of bug 801943
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 10:42 EDT by Henrique Martins
Modified: 2012-07-26 04:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 04:45:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrique Martins 2012-04-24 10:42:44 EDT
Description of problem:
Starting recently my /tmp is full of files named systemd-namespace-XXXXXX that don't go away.  They all seem to be owned by root/mysql thus I'm not sure which component is at fault.  On some of my systems I only run mysql to store amarok's database.

Version-Release number of selected component (if applicable):
systemd-37-17.fc16.x86_64

How reproducible:
Files show up and remain after reboot

Steps to Reproduce:
1. Normal use, just boot/reboot the system a couple of times, it needs to have the mysqld service enabled
   
Actual results:
Several systemd-namespace-XXXXXX files remain in /tmp/ after reboot, need manual cleanup.

Expected results:
A cleaner /tmp

Additional info:
Comment 1 Michal Schmidt 2012-04-24 11:12:37 EDT
A part of the problem is bug 810257 that prevents the expected cleanup after 10 days. But even after we fix that bug, we should add active removal of the namespace directories after stopping services.
Comment 2 Wolfgang Denk 2012-07-26 04:38:25 EDT
The same problem is still present in Fedora 17:

system 1:
drwx------ 4 root root       4096 Jul 25 10:33 systemd-namespace-Aj4mKf
drwx------ 4 root colord     4096 Jul 25 10:33 systemd-namespace-lIOUQD
drwx------ 4 root colord     4096 Jul 25 10:33 systemd-namespace-1FbHwg

system 2:
drwx------ 4 root mysql 4096 Jul 20 20:39 systemd-namespace-WFzmLu
drwx------ 4 root mysql 4096 Jul 20 20:39 systemd-namespace-LVkQAu
drwx------ 4 root mysql 4096 Jul 20 20:39 systemd-namespace-I51yMu
drwx------ 2 root mysql 4096 Jul 20 23:17 systemd-namespace-Sbu7nN
drwx------ 2 root root  4096 Jul 21 23:17 systemd-namespace-iIsvJ5
drwx------ 4 root root  4096 Jul 22 03:38 systemd-namespace-oNJdXf
drwx------ 4 root root  4096 Jul 22 03:38 systemd-namespace-ad2wrK
drwx------ 3 root root  4096 Jul 23 23:17 systemd-namespace-znCUoD
drwx------ 2 root mysql 4096 Jul 23 23:17 systemd-namespace-uBRbAl
drwx------ 3 root mysql 4096 Jul 23 23:17 systemd-namespace-qxHXWv
drwx------ 3 root root  4096 Jul 23 23:17 systemd-namespace-VIAgrJ
drwx------ 2 root root  4096 Jul 23 23:17 systemd-namespace-Sbcm9x
Comment 3 Michal Schmidt 2012-07-26 04:45:27 EDT

*** This bug has been marked as a duplicate of bug 801943 ***

Note You need to log in before you can comment on or make changes to this bug.