Bug 815826 - glaxium will sometimes crash when doing a benchmark or simply playing
glaxium will sometimes crash when doing a benchmark or simply playing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glaxium (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 11:36 EDT by Hans Otten
Modified: 2012-05-12 21:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: glaxium-0.5-13.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 18:56:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch for this bug (458 bytes, patch)
2012-04-24 11:47 EDT, Hans Otten
no flags Details | Diff

  None (edit)
Description Hans Otten 2012-04-24 11:36:57 EDT
Description of problem:
glaxium will sometimes crash when doing a benchmark or simply playing. The crash is due to a segmentation violation.

Version-Release number of selected component (if applicable):
0.5-10.fc16

How reproducible:
always (on my 2 systems with NVidia based graphic cards)

Steps to Reproduce:
1. start glaxium
2. press F3 to start the benchmark or press space to play the game
3.
  
Actual results:
A "Segmentation fault" occurs.

Expected results:
Either the benchmark or the game should have started.

Additional info:
Comment 1 Hans Otten 2012-04-24 11:47:25 EDT
Created attachment 579897 [details]
A patch for this bug

The root cause of the bug turned out to be an index out of bounds access to the fighter2_meshes array in fighter2.cpp. Although there are only 578 faces in the array the loop starting at fighter2.cpp:90 tries to run through 587 faces. See also the file "modeles/fighter2.c".

An even better patch would make all this depend on the size of the fighter2_meshes array itself.
Comment 2 Hans de Goede 2012-05-03 04:00:06 EDT
Thanks for the bug report and the patch! I'm preparing an updated version of glaxium incorporating your fix now.
Comment 3 Fedora Update System 2012-05-03 04:31:59 EDT
glaxium-0.5-13.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/glaxium-0.5-13.fc16
Comment 4 Fedora Update System 2012-05-03 04:32:26 EDT
glaxium-0.5-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/glaxium-0.5-13.fc17
Comment 5 Fedora Update System 2012-05-03 12:01:03 EDT
Package glaxium-0.5-13.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glaxium-0.5-13.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7213/glaxium-0.5-13.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-04 18:56:28 EDT
glaxium-0.5-13.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-05-12 21:59:20 EDT
glaxium-0.5-13.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.