This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 815829 - nfs4 mounts in fstab fail to mount because nfs module not loaded at boot
nfs4 mounts in fstab fail to mount because nfs module not loaded at boot
Status: CLOSED DUPLICATE of bug 806333
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 11:43 EDT by Alastair Neil
Modified: 2012-04-25 00:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 00:42:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alastair Neil 2012-04-24 11:43:25 EDT
Description of problem:
nfs4 mounts in fstab fail to mount because nfs module not loaded at boot

Version-Release number of selected component (if applicable):
1.2.5
14.fc17

How reproducible:
always

Steps to Reproduce:
1.reboot
2.note failure to mount in boot messages 
3.mount -a after boot returns: mount.nfs4: No such device
  
Actual results:
nfs4 files systems not mounted

Expected results:
nfs4 file systems mounted

Additional info:

using sec=krb5, nfs-secure.service and nfs-lock.service  enabled in systemd

manually loading the nfs module resolves the issue:

[aneil2@island ~]$ sudo mount -a
[sudo] password for aneil2: 
mount.nfs4: No such device
[aneil2@island ~]$ lsmod | grep nfs
[aneil2@island ~]$ sudo modprobe nfs
[aneil2@island ~]$ sudo mount -a
[aneil2@island ~]$ df
Filesystem                          1K-blocks    Used Available Use% Mounted on
rootfs                              52327276  5727120  43978716  12% /
devtmpfs                            4013916         4   4013912   1% /dev
tmpfs                               4023712       168   4023544   1% /dev/shm
tmpfs                               4023712      1492   4022220   1% /run
/dev/mapper/vg_island-lv_root       52327276  5727120  43978716  12% /
tmpfs                               4023712         0   4023712   0% /sys/fs/cgroup
tmpfs                               4023712         0   4023712   0% /media
/dev/sda2                           508745      99588    383557  21% /boot
/dev/mapper/vg_island-lv_home       92982552 49210320  39115900  56% /home
vsnfs.vsnet.gmu.edu:/VS/home/       65955840     1024  65954816   1% /VS/home
Comment 1 Braden McDaniel 2012-04-25 00:42:56 EDT

*** This bug has been marked as a duplicate of bug 806333 ***

Note You need to log in before you can comment on or make changes to this bug.