Bug 815832 - Seam faces fails to deploy without Pretty faces on EAP6
Seam faces fails to deploy without Pretty faces on EAP6
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: jbossas (Show other bugs)
6.0
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 11:49 EDT by Adam Kovari
Modified: 2015-08-31 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 04:11:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demo app with pom.xml included (3.62 KB, application/zip)
2012-04-24 11:49 EDT, Adam Kovari
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker AS7-290 Major Resolved CNFEs for Seam 3 optional dependencies 2012-09-26 15:45:06 EDT
JBoss Issue Tracker SEAMFACES-187 Major Resolved Seam faces fails to deploy without Pretty faces on AS7 2012-09-26 15:45:07 EDT

  None (edit)
Description Adam Kovari 2012-04-24 11:49:03 EDT
Created attachment 579898 [details]
demo app with pom.xml included

Description of problem:
Deploying application with following dependency:
		<dependency>
			<groupId>org.jboss.seam.faces</groupId>
			<artifactId>seam-faces</artifactId>
			<version>3.1.0.Final</version>
			<scope>runtime</scope>
		</dependency>

Causes following output:
17:40:00,409 INFO  [org.jboss.weld.ClassLoading] (MSC service thread 1-3) catching: org.jboss.weld.resources.spi.ResourceLoadingException: java.lang.ClassNotFoundException: org.jboss.seam.faces.rewrite.RewriteConfiguration from [Module "deployment.exam.war:main" from Service Module Loader]
	at org.jboss.as.weld.WeldModuleResourceLoader.classForName(WeldModuleResourceLoader.java:74) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.weld.bootstrap.BeanDeployer.loadClass(BeanDeployer.java:98) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.BeanDeployer.addClass(BeanDeployer.java:77) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.BeanDeployer.addClasses(BeanDeployer.java:123) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.BeanDeployment.createBeans(BeanDeployment.java:184) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.WeldBootstrap.deployBeans(WeldBootstrap.java:349) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.as.weld.WeldContainer.start(WeldContainer.java:82) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.weld.services.WeldService.start(WeldService.java:76) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_31]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_31]
	at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]
Caused by: java.lang.ClassNotFoundException: org.jboss.seam.faces.rewrite.RewriteConfiguration from [Module "deployment.exam.war:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at org.jboss.as.weld.WeldModuleResourceLoader.classForName(WeldModuleResourceLoader.java:68) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	... 12 more


Workaround is to add prettyfaces dependency:
		<dependency>
			<groupId>com.ocpsoft</groupId>
			<artifactId>prettyfaces-jsf2</artifactId>
			<version>3.3.2</version>
		</dependency>

Then deployment works fine.

Version-Release number of selected component (if applicable):
JBoss EAP 6.0 beta and ER5

How reproducible:
Always

Steps to Reproduce:
1. Deploy attached demo
2.
3.
  
Actual results:
unsuccessful deployment

Expected results:
successful deployment

Additional info:
please request
Comment 1 Marek Novotny 2012-04-25 04:08:25 EDT
Seam 3 is not in any way tested, supported on EAP6 JBoss AS. This issue will be rejected

Note You need to log in before you can comment on or make changes to this bug.