This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 815876 - [abrt] picard-0.16-1.fc16: script.py:105:__raise_eof:EndOfFile: Unexpected end of script at position 64, line 1
[abrt] picard-0.16-1.fc16: script.py:105:__raise_eof:EndOfFile: Unexpected en...
Status: CLOSED DUPLICATE of bug 768781
Product: Fedora
Classification: Fedora
Component: picard (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
abrt_hash:279b29dad64efc16ad303b527ee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 13:43 EDT by Paulo Ferreira
Modified: 2012-05-08 14:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 14:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Ferreira 2012-04-24 13:43:57 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/picard
executable:     /usr/bin/picard
kernel:         3.3.2-1.fc16.x86_64
reason:         script.py:105:__raise_eof:EndOfFile: Unexpected end of script at position 64, line 1
time:           Ter 24 Abr 2012 13:45:51 BRT
uid:            1000
username:       locoonline

backtrace:
:script.py:105:__raise_eof:EndOfFile: Unexpected end of script at position 64, line 1
:
:Traceback (most recent call last):
:  File "/usr/lib64/python2.7/site-packages/picard/ui/options/renaming.py", line 71, in check_formats
:    self.update_examples()
:  File "/usr/lib64/python2.7/site-packages/picard/ui/options/renaming.py", line 98, in update_examples
:    example1 = self._example_to_filename(self.example_1())
:  File "/usr/lib64/python2.7/site-packages/picard/ui/options/renaming.py", line 89, in _example_to_filename
:    filename = file._make_filename(file.filename, file.metadata, settings)
:  File "/usr/lib64/python2.7/site-packages/picard/file.py", line 229, in _make_filename
:    new_filename = self._script_to_filename(format, metadata, settings)
:  File "/usr/lib64/python2.7/site-packages/picard/file.py", line 202, in _script_to_filename
:    filename = ScriptParser().eval(format, metadata, self)
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 236, in eval
:    ScriptParser._cache[key] = self.parse(script, True)
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 227, in parse
:    return self.parse_expression(True)[0]
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 205, in parse_expression
:    tokens.append(self.parse_function())
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 151, in parse_function
:    return ScriptFunction(name, self.parse_arguments())
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 138, in parse_arguments
:    result, ch = self.parse_expression(False)
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 201, in parse_expression
:    self.__raise_eof()
:  File "/usr/lib64/python2.7/site-packages/picard/script.py", line 105, in __raise_eof
:    raise EndOfFile("Unexpected end of script at position %d, line %d" % (self._x, self._y))
:EndOfFile: Unexpected end of script at position 64, line 1
:
:Local variables in innermost frame:
:self: <picard.script.ScriptParser object at 0x3dd9310>

smolt_data:
:
:
:Geral
:=================================
:UUID: 8d7e9f18-fc0a-4d34-9d11-8572c5b5048d
:SO: Fedora release 16 (Verne)
:Nível de execução padrão: Unknown
:Idioma: pt_BR.utf8
:Plataforma: x86_64
:BogoMIPS: 4256.25
:Fabricante da CPU: GenuineIntel
:Modelo da CPU: Intel(R) Core(TM) i3 CPU       M 330  @ 2.13GHz
:Versão da CPU: 2
:Família da CPU: 6
:Modelo da CPU: 37
:Número de CPUs: 4
:Velocidade da CPU: 2133
:Memória do sistema: 7651
:Swap do sistema: 3813
:Fabricante: Sony Corporation
:Sistema: VPCEB15FB C70046XU
:Fator de uso: Notebook
:Kernel: 3.3.2-1.fc16.x86_64
:SELinux habilitado: 1
:Politica do SELinux: targeted
:Modo de reforço do SELinux: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(32902:68:4173:36977) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(4523:17281:4173:36977) pci, sky2, ETHERNET, Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB]
:(32902:15152:4173:36977) pci, None, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15145:4173:36977) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 4 port SATA AHCI Controller
:(32902:15113:4173:36977) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:4173:36977) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:15174:4173:36977) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 3
:(5772:43:4187:57367) pci, ath9k, NETWORK, AR9285 Wireless Network Adapter (PCI-Express)
:(32902:15164:4173:36977) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:9288:4173:36977) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15204:4173:36977) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(4480:57904:4173:36977) pci, None, BASE, Memory Stick Host Controller
:(4480:59426:4173:36977) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(4480:59426:4173:36977) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(32902:70:4173:36977) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15170:4173:36977) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:4173:36977) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15190:4173:36977) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15156:4173:36977) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15180:4173:36977) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 6
:(32902:11521:4173:36977) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:11362:4173:36977) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11537:4173:36977) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11536:4173:36977) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11539:4173:36977) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11538:4173:36977) pci, None, HOST/PCI, Core Processor Reserved
:
:
:Informações do sistema de arquivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda6 / ext4 4096 4096 5294602 3358572 3305567 1327104 1110952 1110952
:/dev/sda3 WITHHELD ext4 4096 4096 75286849 18528322 14759699 18849792 18432674 18432674
:/dev/sda5 /boot ext4 1024 1024 289067 196720 182128 73152 72915 72915
:
Comment 1 Alex Lancaster 2012-05-01 11:36:11 EDT
Can you describe exactly the set of steps you used to reproduce this?  If it's a problem with a particular file, can you post a link to the file (or an extract)?
Comment 2 Alex Lancaster 2012-05-08 14:54:45 EDT
This looks to be a duplicate of bug #768781 (crash happens at the same line in both bugs).  Please follow up on my request in comment #1 on the bug #768781 if you're still having problems.

*** This bug has been marked as a duplicate of bug 768781 ***

Note You need to log in before you can comment on or make changes to this bug.