Bug 815888 - NetworkManager does not connect to wireless network
NetworkManager does not connect to wireless network
Status: CLOSED DUPLICATE of bug 815091
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 14:13 EDT by cornel panceac
Modified: 2012-04-26 11:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 11:09:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output while trying in vain to connect (74.31 KB, text/x-log)
2012-04-24 14:13 EDT, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2012-04-24 14:13:34 EDT
Created attachment 579945 [details]
dmesg output while trying in vain to connect

Description of problem:
After yum upgrading to f17 from f16, nm no longer connects to the wireless network at startup. It just displays "no network connection" (no wire is connected).

Version-Release number of selected component (if applicable):
$ rpm -q NetworkManager
NetworkManager-0.9.4.0-7.git20120403.fc17.i686

the card is connected through pcmcia  slot.
03:00.0 Network controller [0280]: Ralink corp. RT2500 802.11g [1814:0201] (rev 01)

How reproducible:
always

Steps to Reproduce:
1.log into gnome
2.
3.
  
Actual results:


Expected results:
nm should connect to the available wireless network

Additional info:
things always worked in f16 (excepting the occasional requests for password).
i've tried the f16 kernel and it didn't help. i've also tried with selinux enforcing=0 and it also didn't help. i've added antenna to the wireless router in order to increase the signal, it also didn't help. sometimes if i play with enable/disable wireless/network, it starts working, or at least it displays the available wireless networks and keeps asking for passwords.
Comment 1 Dan Williams 2012-04-24 17:50:02 EDT
This is probably a dupe of 815091 where on F17 right now for some reason wpa_supplicant isn't started correctly by dbus activation.  Can you check /var/log/messages for anything like:

(wlan0): error adding interface: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply time out expired, or the network connection was broken.
9529:Apr 23 21:58:47 rune NetworkManager[781]: dbus_g_proxy_cancel_call: assertion `pending != NULL' failed
Comment 2 cornel panceac 2012-04-25 00:29:08 EDT
Indeed, i've found this in /var/log/messages:

Apr 25 00:17:46 localhost gnome-session[746]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Apr 25 00:17:58 localhost NetworkManager[574]: <error> [1335302278.61158] [nm-supplicant-interface.c:804] interface_add_cb(): (wlan0): error adding interface: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Apr 25 00:17:58 localhost NetworkManager[574]: dbus_g_proxy_cancel_call: assertion `pending != NULL' failed
Apr 25 00:17:58 localhost NetworkManager[574]: <info> (wlan0): supplicant interface state: starting -> down
Apr 25 00:17:58 localhost NetworkManager[574]: <warn> Trying to remove a non-existant call id.
Apr 25 00:17:58 localhost dbus-daemon[614]: dbus[614]: [system] Failed to activate service 'fi.w1.wpa_supplicant1': timed out
Apr 25 00:17:58 localhost dbus[614]: [system] Failed to activate service 'fi.w1.wpa_supplicant1': timed out
Apr 25 00:18:04 localhost systemd[1]: NetworkManager-wait-online.service: main process exited, code=exited, status=1
Apr 25 00:18:04 localhost systemd[1]: Unit NetworkManager-wait-online.service entered failed state.
Apr 25 00:18:04 localhost NetworkManager[574]: <info> wpa_supplicant started
Apr 25 00:18:04 localhost systemd[1]: PID file /run/sendmail.pid not readable (yet?) after start.
Comment 3 Dan Williams 2012-04-26 11:09:58 EDT

*** This bug has been marked as a duplicate of bug 815091 ***

Note You need to log in before you can comment on or make changes to this bug.