Bug 815906 - System hangs when suspending it before screen turns off
System hangs when suspending it before screen turns off
Status: CLOSED DUPLICATE of bug 623573
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 14:45 EDT by Maxim Burgerhout
Modified: 2012-05-04 08:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 08:41:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages snippet from around the suspend (4.46 KB, application/octet-stream)
2012-04-24 14:45 EDT, Maxim Burgerhout
no flags Details

  None (edit)
Description Maxim Burgerhout 2012-04-24 14:45:09 EDT
Created attachment 579964 [details]
/var/log/messages snippet from around the suspend

Description of problem:
When suspending my laptop (see smolt below), it hangs hard. Gnome quits, but the screen remains on showing console login text. After a couple of seconds, the fan starts to blow hard. The laptop remains this way until I manually power it off. 

Version-Release number of selected component (if applicable):
3.3.2-8.fc17.x86_64

How reproducible:
Just try and suspend this laptop, which used to work fine with Fedora 16.

Steps to Reproduce:
1. Press suspend in Gnome or run pm-suspend.
  
Actual results:
Hang.

Expected results:
Suspend.

Additional info:
http://www.smolts.org/client/show/pub_f6b9a9e7-02ad-4f91-9d88-ab69165b3000
Comment 1 Maxim Burgerhout 2012-05-04 08:41:01 EDT
My bad. 'Twas as in bug 798628 and bug 623573 and a whole host of other bugs. This laptop needs a custom script in /etc/pm/sleep.d to unbind the ehci_usb and xhci_usb drivers. I actually used such a script in my F16 install, but completely forgot about it... Closing as duplicate of 623573.

*** This bug has been marked as a duplicate of bug 623573 ***

Note You need to log in before you can comment on or make changes to this bug.