Bug 815907 - iptables does not reflect what /usr/share/system-config-firewall/fw_dbus.py shows
iptables does not reflect what /usr/share/system-config-firewall/fw_dbus.py s...
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-24 14:50 EDT by Donald Cohen
Modified: 2013-02-13 18:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-02-13 18:58:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Donald Cohen 2012-04-24 14:50:40 EDT
Description of problem:
I run the firewall tool and it says sshd is trusted.
But iptables shows no such thing

I can't even tell where it gets its config data, so all I can do is tell you
what I see when I run the tool.
However, I can show the output of iptables (I think this is the default.)
$ iptables -L -n -v
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
1880K 2176M ACCEPT     all  --  *      *              state RELATED,ESTABLISHED
    1    84 ACCEPT     icmp --  *      *             
  142 10202 ACCEPT     all  --  lo     *             
41671 6538K REJECT     all  --  *      *              reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 REJECT     all  --  *      *              reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT 1522K packets, 273M bytes)
 pkts bytes target     prot opt in     out     source               destination  

Needless to say, the behavior I see is what would be expected from the iptables output.

I also can't tell how the data from the UI is supposed to get loaded into the actual firewall settings.
I guess that might not matter if it all worked.
Comment 1 reescf 2012-09-11 17:31:20 EDT
Is this related to https://bugzilla.redhat.com/show_bug.cgi?id=834610 which affects Fedora 17's system-config-firewall?
Comment 2 Fedora End Of Life 2013-01-16 15:33:48 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 3 Fedora End Of Life 2013-02-13 18:58:36 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.