Bug 815953 - ppc64p7 support incomplete
ppc64p7 support incomplete
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
17
ppc64 Linux
high Severity high
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 17:20 EDT by David Aquilina
Modified: 2014-06-23 20:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: rpm-4.9.1.3-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 06:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/lib/rpm/platform/ppc64p7-linux/macros (2.56 KB, text/plain)
2012-04-24 17:20 EDT, David Aquilina
no flags Details

  None (edit)
Description David Aquilina 2012-04-24 17:20:00 EDT
Created attachment 580005 [details]
/usr/lib/rpm/platform/ppc64p7-linux/macros

Description of problem:

When building some rpms with '--target=ppc64p7', rpmbuild will fail with: 

Processing files: sendmail-sysvinit-8.14.5-12.fc17.noarch
error: File must begin with "/": %{_initrddir}/sendmail

It looks like that macro is defined in /usr/lib/rpm/platform/$CPU-$OS/macros. There is no ppc64p7-linux directory there. 

Copying ppc64-linux to ppc64p7-linux and s/ppc64/ppc64p7/ in the macros file fixes the rpmbuild problems and it appears that the proper optimizations are used as well. 

Attaching the /usr/lib/rpm/platform/ppc64p7-linux/macros I used in my single test.
Comment 1 Phil Knirsch 2012-04-25 08:41:23 EDT
Ye, the problem is that the installplatforms script changed between rpm-4.9 and rpm-4.10 so it worked fine on master (4.10) but on rpm-4.9 installplatform didn't detect ppc64p7 as a know arch and didn't autogenerate the platform dir and macro for it.

Fixed it latest rpm-4.9.1.3-3.fc17 that was just built in Fedora.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4021759

Thanks & regards, Phil
Comment 2 David Aquilina 2012-04-27 15:45:07 EDT
This still isn't quite right: 


<mock-chroot>[root@ppc-composer ~]# rpm -q rpm
rpm-4.9.1.3-4.fc17.ppc64
<mock-chroot>[root@ppc-composer ~]# grep '%_lib' /usr/lib/rpm/platform/ppc64p7-linux/macros 
%_libexecdir		%{_exec_prefix}/libexec
%_lib			lib
%_libdir		%{_prefix}/lib


_lib and _libdir should be lib64.
Comment 3 Phil Knirsch 2012-05-08 06:25:53 EDT
Fixed in latest stable version for Fedora 17: http://koji.fedoraproject.org/koji/taskinfo?taskID=4049123

Thanks & regards, Phil

Note You need to log in before you can comment on or make changes to this bug.