Bug 815962 - memory errors (in yum/repoquery/etc)
memory errors (in yum/repoquery/etc)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-24 18:00 EDT by Bill Nottingham
Modified: 2014-03-16 23:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: sqlite-3.7.11-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 20:57:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-04-24 18:00:09 EDT
Description of problem:

[root@nostromo ~]# export MALLOC_CHECK_=2
[root@nostromo ~]# debuginfo-install python repoquery
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
enabling fedora-debuginfo
enabling rpmfusion-free-rawhide-debuginfo
enabling updates-testing-debuginfo
enabling updates-debuginfo
fedora/group_gz                                          | 434 kB     00:00     
Aborted

Well, that's bad.

[root@nostromo ~]# gdb /usr/bin/python
GNU gdb (GDB) Fedora (7.4.50.20120120-40.fc17)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/python...(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install python-2.7.3-3.fc17.x86_64
(gdb) set args /usr/bin/debuginfo-install python repoquery
(gdb) run
Starting program: /usr/bin/python /usr/bin/debuginfo-install python repoquery
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
enabling fedora-debuginfo
enabling rpmfusion-free-rawhide-debuginfo
enabling updates-testing-debuginfo
enabling updates-debuginfo
[New Thread 0x7fffead10700 (LWP 13929)]
[Thread 0x7fffead10700 (LWP 13929) exited]

Program received signal SIGABRT, Aborted.
0x000000323a235915 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt
#0  0x000000323a235915 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x000000323a2370c8 in __GI_abort () at abort.c:91
#2  0x000000323a27efca in malloc_printerr (ptr=0x1511e70, str=
    0x323a376a94 "realloc(): invalid pointer", action=<optimized out>)
    at malloc.c:5032
#3  realloc_check (oldmem=0x1511e70, bytes=96, caller=<optimized out>)
    at hooks.c:283
#4  0x00007ffff1155c10 in sqlite3MemRealloc (pPrior=0x1511e70, nByte=96)
    at sqlite3.c:15357
#5  0x00007ffff113acbb in sqlite3Realloc (pOld=0x1511e70, nBytes=96)
    at sqlite3.c:19126
#6  0x00007ffff1148724 in sqlite3_realloc (pOld=<optimized out>, 
    n=<optimized out>) at sqlite3.c:19151
#7  0x00007ffff1148784 in sqlite3DbRealloc (db=0x14fd120, p=0x1511e70, 
    n=<optimized out>) at sqlite3.c:19261
#8  0x00007ffff114c3f5 in sqlite3StrAccumAppend (N=12, z=
    0x7ffff11b2678 ", rootpage=#%d, sql=%Q WHERE rowid=#%d", p=0x7fffffff6f10)
    at sqlite3.c:20086
#9  sqlite3StrAccumAppend (p=0x7fffffff6f10, z=
    0x7ffff11b2678 ", rootpage=#%d, sql=%Q WHERE rowid=#%d", N=<optimized out>)
    at sqlite3.c:20052
#10 0x00007ffff114c583 in sqlite3VXPrintf (pAccum=pAccum@entry=0x7fffffff6f10, 
---Type <return> to continue, or q <return> to quit---
    useExtended=useExtended@entry=1, fmt=
    0x7ffff11b2684 "%d, sql=%Q WHERE rowid=#%d", ap=ap@entry=0x7fffffff6fa8)
    at sqlite3.c:19572
#11 0x00007ffff114f9b4 in sqlite3VMPrintf (db=db@entry=0x14fd120, 
    zFormat=<optimized out>, ap=ap@entry=0x7fffffff6fa8) at sqlite3.c:20169
#12 0x00007ffff1187e5f in sqlite3NestedParse (pParse=pParse@entry=0x15108d0, 
    zFormat=zFormat@entry=
    0x7ffff11b2648 "UPDATE %Q.%s SET type='%s', name=%Q, tbl_name=%Q, rootpage=#%d, sql=%Q WHERE rowid=#%d") at sqlite3.c:81436
#13 0x00007ffff11885c3 in sqlite3EndTable (pParse=pParse@entry=0x15108d0, 
    pCons=pCons@entry=0x150f2e8, pEnd=pEnd@entry=0x150f308, 
    pSelect=pSelect@entry=0x0) at sqlite3.c:82786
#14 0x00007ffff1184a04 in yy_reduce (yyruleno=32, yypParser=0x150f230)
    at sqlite3.c:109964
#15 sqlite3Parser (yyp=yyp@entry=0x150f230, yymajor=yymajor@entry=1, yyminor=
    ..., pParse=pParse@entry=0x15108d0) at sqlite3.c:45622
#16 0x00007ffff11876a2 in sqlite3RunParser (pParse=pParse@entry=0x15108d0, 
    zSql=zSql@entry=0x7ffff13ff618 "CREATE TEMPORARY TABLE myTemp (id)", 
    pzErrMsg=pzErrMsg@entry=0x7fffffff74f8) at sqlite3.c:111995
#17 0x00007ffff11891f2 in sqlite3Prepare (db=db@entry=0x14fd120, 
    zSql=zSql@entry=0x7ffff13ff618 "CREATE TEMPORARY TABLE myTemp (id)", 
    nBytes=nBytes@entry=-1, saveSqlFlag=saveSqlFlag@entry=0, 
    pReprepare=pReprepare@entry=0x0, ppStmt=ppStmt@entry=0x7fffffff7608, 
---Type <return> to continue, or q <return> to quit---
    pzTail=pzTail@entry=0x7fffffff7600) at sqlite3.c:94247
#18 0x00007ffff1189459 in sqlite3LockAndPrepare (pzTail=0x7fffffff7600, ppStmt=
    0x7fffffff7608, pOld=0x0, saveSqlFlag=0, nBytes=-1, zSql=
    0x7ffff13ff618 "CREATE TEMPORARY TABLE myTemp (id)", db=0x14fd120)
    at sqlite3.c:94339
#19 sqlite3LockAndPrepare (db=0x14fd120, zSql=
    0x7ffff13ff618 "CREATE TEMPORARY TABLE myTemp (id)", nBytes=-1, 
    saveSqlFlag=0, pOld=0x0, ppStmt=0x7fffffff7608, pzTail=0x7fffffff7600)
    at sqlite3.c:28786
#20 0x00007ffff11898b5 in sqlite3_prepare (db=db@entry=0x14fd120, 
    zSql=zSql@entry=0x7ffff13ff618 "CREATE TEMPORARY TABLE myTemp (id)", 
    nBytes=nBytes@entry=-1, ppStmt=ppStmt@entry=0x7fffffff7608, 
    pzTail=pzTail@entry=0x7fffffff7600) at sqlite3.c:94402
#21 0x00007ffff118fe28 in sqlite3_exec (db=0x14fd120, zSql=
    0x7ffff13ff618 "CREATE TEMPORARY TABLE myTemp (id)", xCallback=0, pArg=
    0x0, pzErrMsg=0x0) at sqlite3.c:90860
#22 0x00007ffff13ecfdc in ?? () from /lib64/libsoftokn3.so
#23 0x00007ffff13ed569 in ?? () from /lib64/libsoftokn3.so
#24 0x00007ffff13f0d85 in ?? () from /lib64/libsoftokn3.so
#25 0x00007ffff13db30c in ?? () from /lib64/libsoftokn3.so
#26 0x00007ffff13db902 in ?? () from /lib64/libsoftokn3.so
#27 0x00007ffff13dbda9 in ?? () from /lib64/libsoftokn3.so
#28 0x000000324b24658a in PK11_CreateNewObject (slot=slot@entry=0x719ea0, 
---Type <return> to continue, or q <return> to quit---
    session=1, theTemplate=theTemplate@entry=0x7fffffff7a50, count=count@entry=
    2, token=token@entry=0, objectID=objectID@entry=0x7fffffff7a48)
    at pk11obj.c:412
#29 0x000000324b257f50 in secmod_UserDBOp (slot=slot@entry=0x719ea0, 
    objClass=objClass@entry=3461563221, sendSpec=sendSpec@entry=
    0x14de2d0 "tokens=[0x4=<configdir='sql:/etc/pki/nssdb' tokenDescription='NSS system database' >]") at pk11util.c:1310
#30 0x000000324b258565 in SECMOD_OpenNewSlot (mod=mod@entry=0x711d40, 
    moduleSpec=moduleSpec@entry=
    0x14dcfb0 "configdir='sql:/etc/pki/nssdb' tokenDescription='NSS system database' ") at pk11util.c:1417
#31 0x000000324b23e5b0 in secmod_handleReload (newModule=0x14de020, oldModule=
    0x711d40) at pk11load.c:173
#32 secmod_ModuleInit (mod=mod@entry=0x14de020, reload=reload@entry=
    0x7fffffff7c88, alreadyLoaded=alreadyLoaded@entry=0x7fffffff7bb4)
    at pk11load.c:265
#33 0x000000324b23ea3b in secmod_LoadPKCS11Module (mod=mod@entry=0x14de020, 
    oldModule=oldModule@entry=0x7fffffff7c88) at pk11load.c:488
#34 0x000000324b24b7fd in SECMOD_LoadModule (modulespec=modulespec@entry=
    0x14ddd40 "library= module=\"NSS system database\" parameters=\"configdir='sql:/etc/pki/nssdb' tokenDescription='NSS system database' \" NSS=\"trustOrder=80 cipherOrder=100 slotParams={0x00000001=[slotFlags=RSA,RC4,R"..., 
    parent=parent@entry=0x14dd4f0, recurse=recurse@entry=1) at pk11pars.c:1121
---Type <return> to continue, or q <return> to quit---
#35 0x000000324b24b980 in SECMOD_LoadModule (modulespec=modulespec@entry=
    0x14dd2f0 "library=\"libnsssysinit.so\" name=\"NSS Internal PKCS #11 Module\" NSS=\"Flags=internal,moduleDBOnly,critical trustOrder=75 cipherOrder=100 slotParams=(1={slotFlags=[RSA,DSA,DH,RC2,RC4,DES,RANDOM,SHA1,MD5,"..., 
    parent=parent@entry=0x14dcc50, recurse=recurse@entry=1) at pk11pars.c:1156
#36 0x000000324b24b980 in SECMOD_LoadModule (modulespec=modulespec@entry=
    0x14dc980 "name=\"NSS Internal Module\" parameters=\"configdir='sql:/etc/pki/nssdb' certPrefix='' keyPrefix='' secmod='' flags=readOnly updatedir='' updateCertPrefix='' updateKeyPrefix='' updateid='' updateTokenDes"..., 
    parent=parent@entry=0x0, recurse=recurse@entry=1) at pk11pars.c:1156
#37 0x000000324b21ac22 in nss_InitModules (isContextInit=1, optimizeSpace=0, 
    forceOpen=0, noModDB=0, noCertDB=0, readOnly=1, 
    pwRequired=<optimized out>, configStrings=0xc155d0 " minPS=0", configName=
    0x324b2fb7c8 "NSS Internal Module", updateName=0x324b2fbd37 "", updateID=
    0x324b2fbd37 "", updKeyPrefix=0x324b2fbd37 "", updCertPrefix=
    0x324b2fbd37 "", updateDir=<optimized out>, secmodName=0x3345c54888 "", 
    keyPrefix=<optimized out>, certPrefix=<optimized out>, configdir=
    0xc0f2b0 "sql:/etc/pki/nssdb") at nssinit.c:469
#38 nss_Init (configdir=0xc0f2b0 "sql:/etc/pki/nssdb", 
    certPrefix=<optimized out>, keyPrefix=<optimized out>, secmodName=
    0x3345c54888 "", updateDir=updateDir@entry=0x324b2fbd37 "", 
    updCertPrefix=updCertPrefix@entry=0x324b2fbd37 "", 
    updKeyPrefix=updKeyPrefix@entry=0x324b2fbd37 "", updateID=updateID@entry=
---Type <return> to continue, or q <return> to quit---
    0x324b2fbd37 "", updateName=updateName@entry=0x324b2fbd37 "", 
    initContextPtr=initContextPtr@entry=0x7fffffff7f28, initParams=
    0x7fffffff7f50, readOnly=1, noCertDB=0, noModDB=0, forceOpen=0, 
    noRootInit=noRootInit@entry=1, optimizeSpace=0, noSingleThreadedModules=0, 
    allowAlreadyInitializedModules=1, dontFinalizeModules=0) at nssinit.c:674
#39 0x000000324b21b541 in NSS_InitContext (configdir=<optimized out>, 
    certPrefix=<optimized out>, keyPrefix=<optimized out>, 
    secmodName=<optimized out>, initParams=<optimized out>, 
    flags=<optimized out>) at nssinit.c:865

#40 0x0000003345c3fbc3 in ?? () from /lib64/libcurl.so.4
#41 0x0000003345c40345 in ?? () from /lib64/libcurl.so.4
#42 0x0000003345c3774b in ?? () from /lib64/libcurl.so.4
#43 0x0000003345c0fea0 in ?? () from /lib64/libcurl.so.4
#44 0x0000003345c217cc in ?? () from /lib64/libcurl.so.4
#45 0x0000003345c21a9a in ?? () from /lib64/libcurl.so.4
#46 0x0000003345c367c4 in ?? () from /lib64/libcurl.so.4
#47 0x0000003345c294f1 in ?? () from /lib64/libcurl.so.4
#48 0x00007fffed9e1182 in ?? ()
   from /usr/lib64/python2.7/site-packages/pycurl.so
#49 0x000000391b8dce46 in PyEval_EvalFrameEx () from /lib64/libpython2.7.so.1.0
(whole lot of similar PyEval frames snipped)
#138 0x000000391b8f79a2 in PyRun_FileExFlags () from /lib64/libpython2.7.so.1.0
#139 0x000000391b8f83bb in PyRun_SimpleFileExFlags ()
   from /lib64/libpython2.7.so.1.0
#140 0x000000391b909892 in Py_Main () from /lib64/libpython2.7.so.1.0
#141 0x000000323a221735 in __libc_start_main (main=0x4006c0 <main>, argc=4, 
    ubp_av=0x7fffffffe4c8, init=<optimized out>, fini=<optimized out>, 
    rtld_fini=<optimized out>, stack_end=0x7fffffffe4b8) at libc-start.c:226
#142 0x00000000004006f1 in _start ()
(gdb) 

Version-Release number of selected component (if applicable):

sqlite-3.7.11-1.fc17.x86_64
python-2.7.3-3.fc17.x86_64
yum-3.4.3-23.fc17.noarch

How reproducible:

100%

Steps to Reproduce:
1. Install new sqlite
2. Watch yum and assorted other things go bananas
Comment 1 Bill Nottingham 2012-04-24 18:03:20 EDT
Downgrading just sqlite fixes it.
Comment 2 Ben Boeckel 2012-04-24 18:38:37 EDT
Looks similar to Bug #801981 indeed.
Comment 3 Ryan Rix 2012-04-25 01:33:00 EDT
I hit this issue in a few places after updating to Beefy Beta, it was fixed by downgrading. Looks like -11 is hosed. :\
Comment 4 Fedora Update System 2012-04-25 03:19:44 EDT
sqlite-3.7.11-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-6327/sqlite-3.7.11-2.fc17
Comment 5 Fedora Update System 2012-04-26 15:29:10 EDT
Package sqlite-3.7.11-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sqlite-3.7.11-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6327/sqlite-3.7.11-2.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-28 20:57:54 EDT
sqlite-3.7.11-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.