Bug 815966 - Can't install RHEL 6.3 beta on IBM 3650 M3 and others due to video problem
Summary: Can't install RHEL 6.3 beta on IBM 3650 M3 and others due to video problem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-mga
Version: 6.3
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: beta
: 6.3
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 842499
TreeView+ depends on / blocked
 
Reported: 2012-04-24 22:08 UTC by Don Dettke
Modified: 2012-07-31 05:56 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-drv-mga-1.4.13-7.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Installing RHEL6.3 beta on IBM 3650 M3 (and other IBM models.) I was using an Avocent KVM for the video console but a co-worker had the same problem with a monitor connected directly to the VGA port on the server. The server has on-board Matrox MGA G200EV video.
Last Closed: 2012-07-12 19:02:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
Anaconda log (3.61 KB, text/plain)
2012-04-24 22:08 UTC, Don Dettke
no flags Details
program.log (1.86 KB, text/plain)
2012-04-24 22:11 UTC, Don Dettke
no flags Details
X.log (38.65 KB, text/plain)
2012-04-24 22:11 UTC, Don Dettke
no flags Details
syslog (101.63 KB, text/plain)
2012-04-24 22:16 UTC, Don Dettke
no flags Details
Xorg.0.log using driver xorg-x11-drv-mga-1.4.13-6.el6.i686.rpm (52.00 KB, text/plain)
2012-04-26 17:46 UTC, Don Dettke
no flags Details
Xorg.0.log with updated mga driver (52.14 KB, text/plain)
2012-04-26 18:07 UTC, Don Dettke
no flags Details
xorg-x11-drv-mga-1.4.13-6.el6.test1.i686-panel.png (986.13 KB, image/png)
2012-05-30 06:47 UTC, Haruo Tomita
no flags Details
xorg-x11-drv-mga-1.4.13-3.el6.i686-panel.png (980.80 KB, image/png)
2012-05-30 06:48 UTC, Haruo Tomita
no flags Details
xorg-x11-drv-vesa-2.3.0-2.el6-panel.png (487.72 KB, image/png)
2012-05-31 22:59 UTC, Haruo Tomita
no flags Details

Description Don Dettke 2012-04-24 22:08:41 UTC
Created attachment 580011 [details]
Anaconda log

Description of problem:
During attempted installation of RHEL6.3 beta on IBM 3650 M3 and other IBM models, the monitor goes completely black as soon as anaconda starts the graphic mode installation.  The installation can't continue.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.10.6-1.el6.i686
xorg-x11-drv-vesa-2.3.0-2.el6.i686

How reproducible:
100%

Steps to Reproduce:
1.  Attempt to install RHEL6.3 beta on an IBM 3650 M3 (or some other IBM models.)
2.  Select the default graphic installation.
3.  As soon as anaconda starts the graphic installation the screen goes black and stays that way.
  
Actual results:
Unable to install OS.

Expected results:
Normal graphic installation.

Additional info:
I was able to work around the problem by selecting a "Basic Video mode" installation.  The graphic installation still started with a black screen but I
was able to change to a different resolution (<ctrl><alt><+> or <ctrl><alt><->)
and then moving the cursor around on the screen would cause the screen to be painted as it was re-drawn.  When I had "redrawn" enough of the interface to see a button, I clicked the button and ater that, the new window was rendered relatively normal and I was able to complete the installation without too much more trouble.

Comment 1 Don Dettke 2012-04-24 22:11:03 UTC
Created attachment 580013 [details]
program.log

Comment 2 Don Dettke 2012-04-24 22:11:59 UTC
Created attachment 580014 [details]
X.log

Comment 4 Don Dettke 2012-04-24 22:16:45 UTC
Created attachment 580018 [details]
syslog

syslog shows kernel complaining about "Invalid ROM contents" on the Matrox video device...

15:59:02,506 ERR kernel:pci 0000:07:00.0: Invalid ROM contents

# lspci |grep 07:00.0
07:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200EV


...but this is also seen in earlier releases of RHEL that didn't have this video problem.

Comment 5 Adam Jackson 2012-04-26 14:24:37 UTC
This is a bug in the mga driver.  The vesa driver is what worked for you.

Can you test with the following updated package?

http://people.redhat.com/~ajackson/815966/

Comment 6 Don Dettke 2012-04-26 17:46:29 UTC
Created attachment 580523 [details]
Xorg.0.log using driver xorg-x11-drv-mga-1.4.13-6.el6.i686.rpm

Hi Adam,
I loaded the i686 mga package on the system I managed to get installed using basic video mode and deleted the (minimal) xorg.conf that specified the vesa driver and restarted X and was unable to get anything to display.  The Xorg.0.log is attached.

Comment 7 Don Dettke 2012-04-26 18:07:08 UTC
Created attachment 580526 [details]
Xorg.0.log with updated mga driver

The Xorg.0.log I attached earlier was with a hacked xorg.conf.  This attachment is the right one, after I had deleted the xorg.conf.

Comment 8 Don Dettke 2012-04-26 18:13:02 UTC
OK -- this is really weird...
After sitting idle for some time, the login screen was displayed but it goes black as soon as there is any input (mouse movement.)  Almost like a case of dyslexia with the screen saver.

Comment 9 Adam Jackson 2012-05-16 17:50:00 UTC
Sigh, looks like the RANDR 1.2 feature isn't ready on those chips yet.  Easy enough to back out, but unpleasant.

If you use an xorg.conf like:

Section "Device"
    Identifier "mga"
    Driver "mga"
    Option "RANDR12" "off"
EndSection

do you get a working display?

Comment 10 Don Dettke 2012-05-17 23:44:58 UTC
Hi Adam,

With the xorg.conf you specified, when I kill the X server and it restarts, the Login screen displays fine.  But as soon as I log in there the signal is lost.

Comment 11 Adam Jackson 2012-05-18 21:34:46 UTC
Okay, I think I know what this is.  Please try this new test driver (without the xorg.conf hack above):

http://people.redhat.com/~ajackson/815966/

Comment 12 Don Dettke 2012-05-18 22:06:53 UTC
Hi Adam,
It works!  I didn't do extensive testing but after starting X with the test driver and logging in the desktop is displayed correctly.
Thanks!
Don

Comment 13 IBM Bug Proxy 2012-05-28 17:20:53 UTC
The bug has been fixed as Don Dettke commented at RedHat bugzilla.

https://bugzilla.redhat.com/show_bug.cgi?id=815966

Comment 14 Haruo Tomita 2012-05-30 06:45:22 UTC
(In reply to comment #12)
> It works!  I didn't do extensive testing but after starting X with
> the test driver and logging in the desktop is displayed correctly.

Hi don,
As for xorg-x11-drv-mga-1.4.13-6.el6.test1.i686.rpm, in my environment, 
a panel is not displayed correctly. 
The icon of "Register System", "Network Conection", and ... are not displayed on a panel.
(See attached file: xorg-x11-drv-mga-1.4.13-6.el6.test1.i686-panel.png)

There is no problem in the driver of RHEL6.2. 
(See attached file: xorg-x11-drv-mga-1.4.13-3.el6.i686-panel.png)

Is a panel displayed correctly in your environment?

Comment 15 Haruo Tomita 2012-05-30 06:47:27 UTC
Created attachment 587603 [details]
xorg-x11-drv-mga-1.4.13-6.el6.test1.i686-panel.png

Comment 16 Haruo Tomita 2012-05-30 06:48:58 UTC
Created attachment 587609 [details]
xorg-x11-drv-mga-1.4.13-3.el6.i686-panel.png

Comment 17 Don Dettke 2012-05-31 18:51:16 UTC
Hi Haruo,
The Sound and Network Manager applet icons are displayed on the panel, as expected, in RHEL6.3 snapshot4 (with both the vesa driver and the mga test driver) on my IBM 3650 M3.  Even if they aren't on your system I don't think that would be related to the mga driver.  I think it would be something from gnome, or possibly a difference in the hardware detected on the system.

Comment 18 Haruo Tomita 2012-05-31 22:57:32 UTC
Hi DOn,

Thank you for explaining it.
In my environment, an icon is displayed on a panel vesa-2.3.0-2.el6 and mga-1.4.13-3.el6. However, an icon is not displayed on a panel drv-mga-1.4.13-6.el6 and drv-mga-1.4.13-6.el6.test1. (See attached file: xorg-x11-drv-vesa-2.3.0-2.el6-panel.png)

I think that the issue as which an icon is not displayed on a panel is related to a mga driver.

Comment 19 Haruo Tomita 2012-05-31 22:59:27 UTC
Created attachment 588209 [details]
xorg-x11-drv-vesa-2.3.0-2.el6-panel.png

Comment 20 Haruo Tomita 2012-06-01 02:22:46 UTC
In mga-1.4.13-6.el6 of RHEL6.3 snapshot4, although Network Manager applet icon is running, it is not displayed on a panel. Notification Area cannot be added to a panel. 

[root@localhost ~]# cat /var/log/Xorg.0.log | grep mga
[   350.947]            Identifier      "Builtin Default mga Device 0"
[   350.947]            Driver  "mga"
[   350.947]            Identifier      "Builtin Default mga Screen 0"
[   350.947]            Device  "Builtin Default mga Device 0"
[   350.947]            Screen  "Builtin Default mga Screen 0"
[   350.947] (**) |-->Screen "Builtin Default mga Screen 0" (0)
[   350.947] (**) |   |-->Device "Builtin Default mga Device 0"
[   350.947] (==) No monitor specified for screen "Builtin Default mga Screen 0".
[   350.952] (II) LoadModule: "mga"
[   350.952] (II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
[   350.968] (II) Module mga: vendor="X.Org Foundation"
[   350.970] (II) MGA: driver for Matrox chipsets: mga2064w, mga1064sg, mga2164w,
        mga2164w AGP, mgag100, mgag100 PCI, mgag200, mgag200 PCI,
        mgag200 SE A PCI, mgag200 SE B PCI, mgag200 EV Maxim,
        mgag200 ER SH7757, mgag200 eW Nuvoton, mgag200eH, mgag400, mgag550
[   350.976] (II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
[   350.994] (--) MGA(0): Chipset: "mgag200 SE A PCI"
        "Builtin Default mga Screen 0" for depth/fbbpp 24/24
[root@localhost ~]# pidof nm-applet
3811
[root@localhost ~]# kill -9 3811
[root@localhost ~]# pidof nm-applet
[root@localhost ~]# nm-applet --sm-disable &
[1] 4086
[root@localhost ~]# ** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area

[root@localhost ~]#

Comment 22 Don Dettke 2012-06-14 00:04:49 UTC
I verified that RHEL6.3 RC (i686) contains the driver package with the fix and that video does work with that mga driver.

[root@hb131222-RH63-rc1 ~]# rpm -qa|grep mga
xorg-x11-drv-mga-1.4.13-7.el6.i686

Comment 23 Adam Jackson 2012-07-12 19:02:30 UTC
Closing per comment #22.


Note You need to log in before you can comment on or make changes to this bug.