Bug 815997 - Anaconda showing a blank screen during graphical installs
Anaconda showing a blank screen during graphical installs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-mga (Show other bugs)
6.3
x86_64 Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: OtherQA, Regression
Depends On: 821956
Blocks: 711169
  Show dependency treegraph
 
Reported: 2012-04-24 22:10 EDT by James Takahashi
Modified: 2014-07-25 02:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-drv-mga-1.4.13-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:35:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error messages seen on console 5 (59.13 KB, image/jpeg)
2012-04-24 22:12 EDT, James Takahashi
no flags Details
requested log files (60.00 KB, application/x-tar)
2012-04-25 22:20 EDT, IBM Bug Proxy
no flags Details
snap3 logs (29.74 KB, application/x-compressed)
2012-05-17 02:00 EDT, IBM Bug Proxy
no flags Details
snap4 logs (27.35 KB, application/x-compressed)
2012-05-24 21:11 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 81065 None None None Never

  None (edit)
Description James Takahashi 2012-04-24 22:10:09 EDT
Description of problem:
When installing to IBM System x servers in graphical mode with a local monitor (both direct attached and kvm-attached monitors hit this problem), the screen goes blank at the first graphical screen following the initial red/white/blue screens.

If I try to view what's going on via the IMM's remote console, all is well... the graphical screen looks fine via that method.  VNC installs also work fine. All the text consoles are selectable via ctrl-alt-Fn and alive. And even though console 6's display is blank, it is accepting keyboard input.  Console 5 seems to have some display-related errors (screenshot attached).

Version-Release number of selected component (if applicable):
Seen in both the alpha and beta1 drops.

How reproducible:
Every time.

Steps to Reproduce:
1. Attempt to install RH6.3 to an IBM System x platform
2. Reply to the queries on the red/white/blue screens.
3. Screen goes black. At first glance, it seems like the install has died, but as I mention elsewhere, it's actually alive and well.
  
Actual results:
Black screen

Expected results:
Beautiful graphical screen

Additional info:
I've spoken to various teammates, and no one has yet reported NOT hitting this.  I suspect that all System x platforms are affected. My most recent attempt was on an x3250m3, but I think I also saw this on an x3650m2. A teammate says he also saw it on an x3650m4.

Since we generally install via some remote means, we are not blocked by this issue.  But it's definitely an ugly one that needs to be fixed.
Comment 2 James Takahashi 2012-04-24 22:12:21 EDT
Created attachment 580043 [details]
Error messages seen on console 5
Comment 3 Chris Lumens 2012-04-25 09:49:19 EDT
Can you grab /tmp/anaconda.log and /tmp/X.log?
Comment 4 IBM Bug Proxy 2012-04-25 22:20:40 EDT
Created attachment 580328 [details]
requested log files



(In reply to comment #3)
> 
> Can you grab /tmp/anaconda.log and /tmp/X.log?

Attaching requested log files....
Comment 5 IBM Bug Proxy 2012-04-26 15:50:50 EDT
FYI, a teammate (Gary Hade, now cc'd) notes that this problem is happening on systems that have Matrox video.  Further, he notes that RHEL6.3's xorg-x11-drv-mga RPM has only a single change since RHEL6.2.  Even further, if he installs the RHEL6.2 RPM (1.4.13-3 instead of -4), X will successfully start instead of displaying random colored bars.
Comment 6 David Cantrell 2012-04-26 15:57:58 EDT
From X.log:

[   110.625] (EE) open /dev/fb0: No such device
[   113.362] (EE) MGA(0): [drm] Direct rendering only supported with
G200/G400/G450/G550.
10: 48 EE FC 00 03 20 10 00 03 00 01 00 03 20 10 00 
[   326.288] (EE) IBM IBM Composite Device-0: failed to initialize for relative
axes.

Reassigning.
Comment 7 IBM Bug Proxy 2012-05-02 14:30:41 EDT
Also seen (random colored vertical bars) during an install on an HS23.  Unlike the initial comment, looking at remote video through the BladeCenter AMM (which should be going directly through the IMMv2) there is no improvement.
Comment 8 RHEL Product and Program Management 2012-05-06 00:07:13 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 9 IBM Bug Proxy 2012-05-07 08:30:57 EDT
Red Hat,

It appears that this is a regression from 6.2.  Please consider as such and help fix it prior to the next beta snapshot of of 6.3.  You have 100s of systems onsite where you should also have seen and corrected  this already.

Joe Kachuck - can you please process this as a regression for us?

Thanks,

Monte
Comment 10 IBM Bug Proxy 2012-05-08 13:21:05 EDT
Changing severity to Ship Issue as this is a regression from RH6.2
Comment 11 Joseph Kachuck 2012-05-09 13:15:03 EDT
Hello,
This bug is now requested as a regression for RHEL 6.3.

Thank You
Joe Kachuck
Comment 14 Adam Jackson 2012-05-14 13:54:50 EDT
Please re-test with xorg-x11-drv-mga 1.4.13-6.el6 or later, wherein I'm pretty sure this is already fixed.
Comment 16 RHEL Product and Program Management 2012-05-14 14:19:51 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 17 Tomas Pelka 2012-05-15 03:18:36 EDT
We should have all mentioned machines (x3250m3, x3650m2 and x3650m4) available, but it would be also good if IBM could retest with new mga driver (#c14).

Acking
Comment 22 IBM Bug Proxy 2012-05-17 01:50:49 EDT
(In reply to comment #13)
> Please re-test with xorg-x11-drv-mga 1.4.13-6.el6 or later, wherein I'm
> pretty sure this is already fixed.

Nope, not true.  I just saw the same failure with snap3 which contains xorg-x11-drv-mga-1.4.13-6.el6.x86_64

I'll attach log files shortly.
Comment 23 IBM Bug Proxy 2012-05-17 02:00:38 EDT
Created attachment 585106 [details]
snap3 logs
Comment 25 IBM Bug Proxy 2012-05-24 21:10:52 EDT
I forgot to mention that in this snap4 run, I was wondering whether our KVM might be a factor, so I ran a test both with the KVM and through a direct attached CRT.  Both hit the black screen issue.
Comment 26 IBM Bug Proxy 2012-05-24 21:11:02 EDT
Created attachment 586729 [details]
snap4 logs



The logged results have improved (at least to my untrained eye), yet the screen remains black.  These logs collected from an x3630m3 with Matrox Graphics, Inc. MGA G200EV
Comment 28 IBM Bug Proxy 2012-05-25 14:00:49 EDT
Per a request from Red Hat, I tried ajax's xorg-x11-drv-mga-1.4.13-6.el6.test1.x86_64.rpm test package on the system where I just loaded snap4.

In addition to the GUI installer being black screen, starting X on that system was also hitting the black screen.  With ajax's test driver, X starts fine.

It is my understanding that ajax's new driver will show up in snap5, so we should be able to close this issue when snap5 drops.
Comment 30 IBM Bug Proxy 2012-06-02 03:50:56 EDT
(In reply to comment #24)
> It is my understanding that ajax's new driver will show up in snap5, so we
> should be able to close this issue when snap5 drops.

OK, I verified that this problem is fixed on one of the platforms -- x3630m3 -- that had previously been failing.  Both the GUI installer and X look fine.  OK to close this now.

[root@elm3a165 ~]# uname -a
Linux elm3a165 2.6.32-274.el6.x86_64 #1 SMP Tue May 22 17:56:02 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@elm3a165 ~]# rpm -qi xorg-x11-drv-mga
Name        : xorg-x11-drv-mga             Relocations: (not relocatable)
Version     : 1.4.13                            Vendor: Red Hat, Inc.
Release     : 7.el6                         Build Date: Mon 21 May 2012 01:09:43 PM PDT
Install Date: Sat 02 Jun 2012 12:13:44 AM PDT      Build Host: x86-008.build.bos.redhat.com
Group       : User Interface/X Hardware Support   Source RPM: xorg-x11-drv-mga-1.4.13-7.el6.src.rpm
Size        : 188309                           License: MIT
Signature   : RSA/8, Wed 23 May 2012 07:49:11 AM PDT, Key ID 938a80caf21541eb
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.x.org
Summary     : Xorg X11 mga video driver
Description :
X.Org X11 mga video driver.
[root@elm3a165 ~]# lspci | grep -i matrox
07:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200EV
Comment 32 errata-xmlrpc 2012-06-20 10:35:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0940.html
Comment 33 IBM Bug Proxy 2014-07-25 02:04:33 EDT
------- Comment From jmtt@us.ibm.com 2012-04-26 19:42 EDT-------

------- Comment From whetzel@us.ibm.com 2012-05-02 18:21 EDT-------

------- Comment From mknutson@us.ibm.com 2012-05-07 12:25 EDT-------

------- Comment From jmtt@us.ibm.com 2012-05-08 17:16 EDT-------

------- Comment From jmtt@us.ibm.com 2012-05-17 05:40 EDT-------

------- Comment From jmtt@us.ibm.com 2012-05-25 01:09 EDT-------

------- Comment From jmtt@us.ibm.com 2012-05-25 17:56 EDT-------

------- Comment From jmtt@us.ibm.com 2012-06-02 07:44 EDT-------

Note You need to log in before you can comment on or make changes to this bug.