Bug 816040 - panic at initramfs unpacking failure on EFI Mac boot
panic at initramfs unpacking failure on EFI Mac boot
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Garrett
Fedora Extras Quality Assurance
EFI Mac first=3.3.2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 02:40 EDT by Chris Murphy
Modified: 2013-03-14 14:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 14:44:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
photo of panic (30.27 KB, image/jpeg)
2012-04-25 02:42 EDT, Chris Murphy
no flags Details
photo of panic 2a (51.87 KB, image/jpf)
2012-04-25 03:59 EDT, Chris Murphy
no flags Details
photo of panic 2b (77.45 KB, image/jpf)
2012-04-25 04:02 EDT, Chris Murphy
no flags Details
Test grub (240.37 KB, application/octet-stream)
2012-04-25 11:14 EDT, Matthew Garrett
no flags Details
photo of test grub 1 (30.02 KB, image/jpeg)
2012-04-25 14:19 EDT, Chris Murphy
no flags Details
photo of test grub 2 (24.42 KB, image/jpeg)
2012-04-25 14:38 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-04-25 02:40:15 EDT
Description of problem:
Initramfs unpacking failed: broken padding
Kernel panic

Version-Release number of selected component (if applicable):
kernel 3.3.2-8.fc17.x86_64 on Fedora-Mac-EFI-test.iso located at
http://mjg59.fedorapeople.org/Fedora-Mac-EFI-test.iso 
http://lists.fedoraproject.org/pipermail/devel/2012-April/166326.html



How reproducible:
100%


Steps to Reproduce:
1. gdisk to nuke GPT and MBR off a USB stick.
2. dd if=ISO of=/dev/USB
no other options
3. Boot with option/alt key to bring up Mac's startup disk menu.
4. Choose blue Fedora logo icon labeled EFI Boot.
5. At GRUB menu wait for timeout.
  
Actual results:
panic.
see screenshot.

Expected results:
glorious successful boot.

Additional info:
Screenshot is from MacBook Pro 4,2 (2008).

A MacBook Pro 8,2 (2011) seems to panic also. Screen appears as in this bug, except is freezes about 1/2 way down, and I can't blindly get to a console to reboot as I normally can from livecd-iso-disk based USB sticks.
https://bugzilla.redhat.com/show_bug.cgi?id=765954
Comment 1 Chris Murphy 2012-04-25 02:42:13 EDT
Created attachment 580071 [details]
photo of panic

I said screenshot, I meant photo. Madness.
Comment 2 Chris Murphy 2012-04-25 03:54:29 EDT
Correction: MacBook Pro 4,1 (2008), not 4,2.

Addition 1: When this ISO is burned to a disk, and I CSM boot from it by selecting the "Windows" option, the panic does not occur.
Comment 3 Chris Murphy 2012-04-25 03:59:57 EDT
Created attachment 580087 [details]
photo of panic 2a

Removed 'rhgb quiet' to get more text, and I consistently get a different panic cause than when I don't edit params. This is as early as I can get it. Next shot will contain the panic.
Comment 4 Chris Murphy 2012-04-25 04:02:42 EDT
Created attachment 580088 [details]
photo of panic 2b

This is the shot about 1/3 of a second after 2a. Contains panic message. But not the initramfs problem found in the original report.
Comment 5 Matthew Garrett 2012-04-25 09:39:16 EDT
I suspect this is the same thing in both cases, it's just that the initramfs warning has scrolled too far. I suspect that we're managing to put the initramfs in a memory region that something really doesn't like. Let me take a look at the grub code.
Comment 6 Matthew Garrett 2012-04-25 11:14:39 EDT
Created attachment 580184 [details]
Test grub

Can you take the USB stick, mount partition 2 on it, copy this grub.efi to EFI/BOOT/BOOTX64.efi and then unmount it and try booting the *non*-Fedora logo image. Grub should print some debug messages about allocating pages - can you either grab a picture of that or transcribe it, and let me know?
Comment 7 Chris Murphy 2012-04-25 14:19:19 EDT
Created attachment 580230 [details]
photo of test grub 1

photo of boot results, 580184 test grub, on MBP 4,1
Comment 8 Chris Murphy 2012-04-25 14:38:56 EDT
Created attachment 580236 [details]
photo of test grub 2

photo of boot results, 580184 test grub, on MBP 8,2
Comment 9 Matthew Garrett 2012-04-25 14:53:40 EDT
How much RAM does each of these machines have?
Comment 10 Chris Murphy 2012-04-25 15:01:41 EDT
MBP4,1 = 4G
MBP8,2 = 8G
Comment 11 Matthew Garrett 2012-04-25 15:06:00 EDT
Hm. Haven't been able to reproduce on an MBP 8,2 here.
Comment 12 Chris Murphy 2012-04-25 15:23:49 EDT
Perhaps differences in firmware? This model has had an inordinate number of firmware updates from Apple, possibly a record. I've done at least 4. I see I have the current "EFI Boot ROM" version of MBP81.0047.B27. But I am one behind the SMC Version at 1.69f3 instead of 1.70f5. Conversely, the MBP 4,1 has original EFI firmware, a newer one was never issued, there was one SMC update.

http://support.apple.com/kb/HT1237
Comment 13 Chris Murphy 2012-04-25 16:59:34 EDT
I was confused. The SMC 1.70f5 is for the 8,3. 

The most recent EFI firmware update for this model was Feb 23. I don't know of a linux command to get this information, but on Mac OS it's:
system_profiler | grep ROM
produces:
      Boot ROM Version: MBP81.0047.B27
      ROM Revision: 113-C0170L-573
system_profiler is part of Darwin, and it's also on the ~620MB Recovery HD partition that will fit on a USB boot stick, and boot a Mac.
Comment 14 heiko 2012-05-05 21:23:19 EDT
Have the same symptoms, but not on a Mac.

H/W:
i7 3930K
ASUS Sabertooth X79 MB
32 Gig RAM
120 Gig SSD
WD 2T Green HD
PNY Quadro 600 graphics adapter (Nvidia-based)

Fedora 16 64bit live CD
Tried also 64bit DVD, FC 17 64bit, etc.

Here the story:
Copied Fedora 16 64-bit live CD onto USB stick using both UNetboot and dd command. In both cases the USB stick would eventually boot (after a long delay).
Installed Fedora on the SSD as follows (all ext4 formatted):
/dev/sda1 - /boot
/dev/sda2 - created following LVs:
/dev/mapper/ssd-root /
/dev/mapper/ssd-home /home

/dev/sdb1 - created following LV:
/dev/mapper/vol2-swap as swap drive

Repeatedly tried to boot, but the boot process stops at kernel panic following either init not found or initramfs unpacking failure.

I did different installs, both nogpt and gpt:
/dev/sda1 as BOOTmbr (?) 1 MB
/dev/sda2 as /boot
/dev/sda3 as VG for LVs as listed above.

I can't get the system to boot from disk. Also checked the BIOS settings, and changed them from legacy to UEFI (both didn't help). Furthermore I checked grub.cfg and it points to the kernel files. I also tried to add insmod lvm directly into the grub.cfg, as I haven't seen it in there - didn't help.

The MB has the latest firmware. For comparison, Linux Mint 12 LMDE installs and boots.

Any suggestions are welcome. Hope my report relates to the bug reported.
Comment 15 Josh Boyer 2013-03-14 14:14:35 EDT
Is this still an issue in Fedora 18 with the 3.8.2 kernel?
Comment 16 Chris Murphy 2013-03-14 14:34:30 EDT
Not an issue with any of the Fedora 18 kernels, including 3.8.2.
Comment 17 Josh Boyer 2013-03-14 14:44:51 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.