Bug 816054 - "#<ProviderAccount:0x7fb4b47776b0>" is displayed in UI when provider quota is enforced.
"#<ProviderAccount:0x7fb4b47776b0>" is displayed in UI when provider quota is...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Imre Farkas
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 03:25 EDT by Aziza Karol
Modified: 2016-09-20 01:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The error message displayed when provider quota is enforced is incorrect.'#<ProviderAccount:0x7fb4b47776b0>' should not be displayed and is now refactored. The correct error message is now displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:07:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quota err (229.51 KB, image/png)
2012-04-25 03:26 EDT, Aziza Karol
no flags Details
message - quota already met (114.12 KB, image/png)
2012-09-21 13:59 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Aziza Karol 2012-04-25 03:25:36 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.enforce provider quota for rhevm.
2.Try launching multi instance deployment for rhevm

  
Actual results:
#<ProviderAccount:0x7fb4b47776b0> quota limit too low to launch application blueprint is displayed in UI. see attached screenshot

Expected results:
#<ProviderAccount:0x7fb4b47776b0>  should not be displayed in UI.

Additional info:
rpm -qa | grep  aeolus
aeolus-conductor-doc-0.8.12-1.el6_2.noarch
aeolus-conductor-0.8.12-1.el6_2.noarch
aeolus-conductor-daemons-0.8.12-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.12-1.el6_2.noarch
aeolus-configure-2.5.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 1 Aziza Karol 2012-04-25 03:26:20 EDT
Created attachment 580079 [details]
quota err
Comment 2 wes hayutin 2012-04-25 09:13:19 EDT
Aziza, I have set this bug as a blocker for the 1.0.z release.
Can you also try recreating after selecting a cloud resource cluster.

Thanks
Comment 4 Imre Farkas 2012-08-29 10:37:07 EDT
Patch sent:
https://github.com/aeolusproject/conductor/pull/21
Comment 5 Imre Farkas 2012-09-03 05:57:20 EDT
in 1.1 branch:
commit ef4453cf3988c6f84c0b9771030691db4e25b9bd
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Wed Aug 29 16:11:58 2012 +0200

    Fix notifications
    
    https://bugzilla.redhat.com/show_bug.cgi?id=816054
    (cherry picked from commit ff0a8ad67d0bdb90e7ce493c144cda53c7167cc7)

commit a8ab1b34a795e394771889747dd35f7329eb5958
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Wed Aug 29 16:11:28 2012 +0200

    Refactor find_match_with_common_account
    
    https://bugzilla.redhat.com/show_bug.cgi?id=816054
    (cherry picked from commit 125a34a4dec4bba747451a6086144656a3b75bd1)

commit 24001a029ee14a5aeb17cfe3358fa169aa649a38
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Wed Aug 29 16:11:03 2012 +0200

    Move InstanceMatch filtering logic to ProviderSelection
    
    https://bugzilla.redhat.com/show_bug.cgi?id=816054
    (cherry picked from commit 611b2e0bb1aa2d1142db0d3643edb1f63231f96b)
Comment 7 Ronelle Landy 2012-09-21 13:57:17 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

If a quota is added to rhevm (quota number = number of instances already launched to rhevm) and then the user attempts to launch and additional instance, the following (correct) message is displayed:

*************

Errors

    Some Component Blueprints will not be launched:
    mock_mockuser: Image is not pushed to this Cloud Resource Provider Account
    ec2-us-east-1_AKIAJCBB265A57CGKR2Q: Image is not pushed to this Cloud Resource Provider Account
    ec2-us-west-1_AKIAJCBB265A57CGKR2Q: Image is not pushed to this Cloud Resource Provider Account
    vsphere-default_Administrator: Cloud Resource Profile match not found
    rhevm-default_admin@internal: Cloud Resource Provider Account quota reached

**************

See attached screenshot.

Marking this BZ as 'verified'
Comment 8 Ronelle Landy 2012-09-21 13:59:17 EDT
Created attachment 615565 [details]
message - quota already met
Comment 10 errata-xmlrpc 2012-12-04 10:07:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.