Bug 81608 - smp.h and shced.h give conflicting defines for cpu_online.
smp.h and shced.h give conflicting defines for cpu_online.
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-10 19:54 EST by Aleksey Nogin
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-30 00:01:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2003-01-10 19:54:27 EST
Not sure whether this is a problem or not, but when compiling some custom module
using the stock kernel-source-2.4.20-2.10 from Rawhide, I get

In file included from /usr/src/linux-2.4/include/linux/mm.h:22,
                 from /usr/src/linux-2.4/include/linux/slab.h:14,
                 from /usr/src/linux-2.4/include/asm/pci.h:32,
                 from /usr/src/linux-2.4/include/linux/pci.h:657,
                 from pcibus.c:5:
/usr/src/linux-2.4/include/linux/sched.h:548:1: warning: "cpu_online" redefined
In file included from /usr/src/linux-2.4/include/linux/sched.h:25,
                 from /usr/src/linux-2.4/include/linux/mm.h:22,
                 from /usr/src/linux-2.4/include/linux/slab.h:14,
                 from /usr/src/linux-2.4/include/asm/pci.h:32,
                 from /usr/src/linux-2.4/include/linux/pci.h:657,
                 from pcibus.c:5:
/usr/src/linux-2.4/include/linux/smp.h:87:1: warning: this is the location of
the previous definition

Indeed,  grep shows:

/usr/src/linux-2.4/include/linux/sched.h:548:#define cpu_online(cpu) ((cpu) <
smp_num_cpus)
/usr/src/linux-2.4/include/linux/smp.h:87:#define cpu_online(cpu)              
    ({ BUG_ON((cpu) != 0); 1; })
Comment 1 Arjan van de Ven 2003-01-12 16:55:47 EST
thanks for the report; fixed for next build
Comment 2 Aleksey Nogin 2003-01-15 17:07:34 EST
Still there in 2.4.20-2.15 (built a day after your last comment). I will keep it
closed for now, will reopen if still there next time.
Comment 3 Arjan van de Ven 2003-01-15 17:10:42 EST
I will reopen anyway since the fix gave other shit (unresolved symbols)
will be fixed but not today ;)

Note You need to log in before you can comment on or make changes to this bug.