Bug 816091 - [abrt] kernel: general protection fault: 0000 [#1] SMP
[abrt] kernel: general protection fault: 0000 [#1] SMP
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:33a86b951697d814bfef08f4389...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 05:01 EDT by admin
Modified: 2012-05-15 02:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 02:12:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (3.46 KB, text/plain)
2012-04-25 05:01 EDT, admin
no flags Details

  None (edit)
Description admin 2012-04-25 05:01:17 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.2-6.fc16.x86_64 root=UUID=42ce16a9-4662-4c4a-8fb8-57524e5cb0d4 ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=ru LANG=ru_RU.UTF-8 crashkernel=128M
event_log:      2012-04-25-13:00:41> Smolt profile successfully saved
kernel:         3.3.2-6.fc16.x86_64
reason:         general protection fault: 0000 [#1] SMP 
time:           Ср. 25 апр. 2012 12:56:43

smolt_data:     Binary file, 3541 bytes

backtrace:
:general protection fault: 0000 [#1] SMP 
:CPU 0 
:Modules linked in: fuse ebtable_nat ebtables be2iscsi iscsi_boot_sysfs ppdev ipt_MASQUERADE bnx2i parport_pc iptable_nat nf_nat cnic lp parport uio xt_CHECKSUM cxgb4i cxgb4 cxgb3i iptable_mangle libcxgbi cxgb3 mdio ib_iser bridge fcoe libfcoe libfc lockd rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core scsi_transport_fc scsi_tgt 8021q ib_addr iscsi_tcp libiscsi_tcp libiscsi garp stp llc scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_netbios_ns nf_conntrack_broadcast ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep vhost_net macvtap macvlan tun snd_seq snd_seq_device snd_pcm virtio_net kvm_amd kvm usblp snd_timer snd shpchp sp5100_tco soundcore snd_page_alloc uinput r8169 sunrpc mii edac_core k10temp i2c_piix4 microcode edac_mce_amd ata_generic pata_acpi usb_storage pata_atiixp wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [
:last unloaded: scsi_wait_scan]
:Pid: 2644, comm: yum Not tainted 3.3.2-6.fc16.x86_64 #1 Gigabyte Technology Co., Ltd. GA-880GMA-USB3/GA-880GMA-USB3
:RIP: 0010:[<ffffffff811a29a1>]  [<ffffffff811a29a1>] xattr_resolve_name+0x11/0x70
:RSP: 0018:ffff8801df187da8  EFLAGS: 00010286
:RAX: ffff88017c49a800 RBX: ffff880203498d80 RCX: 0000000000000020
:RDX: ffff8801df187fd8 RSI: ffff8801df187dc0 RDI: fd4686690c3aa4a4
:RBP: ffff8801df187da8 R08: 0000000000000000 R09: ffff8801df187e30
:R10: 000000000000051e R11: 0000000000000020 R12: ffff8801fab96eb0
:R13: ffff8801df187e30 R14: ffff880203498d80 R15: ffff8801fab96f50
:FS:  00007fc816b3c700(0000) GS:ffff88020fc00000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 00007fc816b43000 CR3: 00000001cc61d000 CR4: 00000000000006f0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process yum (pid: 2644, threadinfo ffff8801df186000, task ffff8801c8151730)
:Stack:
: ffff8801df187dd8 ffffffff811a2c29 ffff8801df187dd8 ffff8801df187e30
: 0000000000000000 0000000000000000 ffff8801df187e18 ffffffff811a2ee2
: 0000000000000000 ffff880203498d80 0000000000000000 00007fc816b3c6a0
:Call Trace:
: [<ffffffff811a2c29>] generic_removexattr+0x29/0x60
: [<ffffffff811a2ee2>] vfs_removexattr+0xa2/0x120
: [<ffffffff811a2fb2>] removexattr+0x52/0x80
: [<ffffffff8118cae3>] ? putname+0x33/0x50
: [<ffffffff81191143>] ? user_path_at_empty+0x63/0xa0
: [<ffffffff8119e058>] ? mnt_want_write+0x58/0x70
: [<ffffffff811a3e7c>] sys_removexattr+0x7c/0x90
: [<ffffffff815fc1e9>] system_call_fastpath+0x16/0x1b
:Code: 8b 5d e8 4c 8b 6d f8 c9 c3 90 48 8b 4b 08 eb e7 e8 6e a7 44 00 e8 6f a7 44 00 55 48 89 e5 66 66 66 66 90 4c 8b 0e 4d 85 c9 74 59 <48> 8b 07 48 85 c0 74 47 48 83 c7 08 0f 1f 00 48 8b 08 0f b6 11 
:RIP  [<ffffffff811a29a1>] xattr_resolve_name+0x11/0x70
: RSP <ffff8801df187da8>
Comment 1 admin 2012-04-25 05:01:24 EDT
Created attachment 580102 [details]
File: smolt_data
Comment 2 Dave Jones 2012-04-25 14:11:14 EDT
faulted trying to dereference fd4686690c3aa4a4, which is just a nonsensical address.

can you make sure this machine passes memtest86, just to rule out hardware problems.
Comment 3 admin 2012-04-26 01:04:56 EDT
by the car some cycles of tests of the program pass without mistakes, in OS Windows as problems isn't observed. It is more connected with the work organization with memory of a kernel of *nix of systems
Comment 4 Dave Jones 2012-05-14 15:19:39 EDT
ok, looks like something has corrupted memory. 
can you run with the kernel-debug build, and see if you can reproduce the probelm with that ?

That might show something interesting in dmesg.
Comment 5 admin 2012-05-15 02:12:19 EDT
after kernel updating on version 3.3.4 and above, the problem isn't shown any more.Thanks

For these reasons, the problem isn't become actual. To repeat a problem it was not possible. And really something damaged memory together with this bug as memtest in a month showed other results. Modules of memory went under replacement on a guarantee

Note You need to log in before you can comment on or make changes to this bug.