Bug 816199 - add dependency to rhn-setup for newt-python
add dependency to rhn-setup for newt-python
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
0.9
All Linux
low Severity low
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-04-25 09:33 EDT by Milan Zázrivec
Modified: 2012-11-01 12:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 809241
Environment:
Last Closed: 2012-11-01 12:20:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2012-04-25 09:33:11 EDT
+++ This bug was initially created as a clone of Bug #809241 +++

Created attachment 574619 [details]
patch for newt-python dep

Description of problem:

the rhn-setup tui uses the snack module which is in newt-python package. while the base channels contain newt-python rpm, customers with modified installs that need to use rhn-setup hit a python error since the rhn-setup package does not properly require newt-python: 

The error is
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 26, in <module>
    from up2date_client import tui
  File "/usr/share/rhn/up2date_client/tui.py", line 25, in <module>
    import snack
ImportError: No module named snack
Comment 1 Milan Zázrivec 2012-04-25 09:41:03 EDT
spacewalk.git master: 6d5a4eaa502db93b83a5d79d1e3bf627c8cb5290
Comment 2 Milan Zázrivec 2012-05-02 07:44:47 EDT
spacewalk.git master: 46f95181f48ae030319e8888cbfd40325c296f8e
Comment 3 Jan Pazdziora 2012-10-30 15:25:15 EDT
Moving ON_QA. Packages that address this bugzilla should now be available in yum repos at http://yum.spacewalkproject.org/nightly/
Comment 4 Jan Pazdziora 2012-11-01 12:20:55 EDT
Spacewalk 1.8 has been released: https://fedorahosted.org/spacewalk/wiki/ReleaseNotes18

Note You need to log in before you can comment on or make changes to this bug.