Bug 816206 - object-storage: new account fails to update the key
object-storage: new account fails to update the key
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: object-storage (Show other bugs)
pre-release
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Junaid
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 09:45 EDT by Saurabh
Modified: 2016-01-19 01:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 05:46:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2012-04-25 09:45:32 EDT
Description of problem:

the new account addition fails to update the key and the REST APIs return with "403 Forbidden" error

seen with latest rpms and with original swift things work
Version-Release number of selected component (if applicable):
3.3.0qa37 and gluster-swift-1.0

How reproducible:


Steps to Reproduce:
1. add a new account in proxy-server
2. try sending GET command to server
3.
  
Actual results:
fails with 403 forbidden


Expected results:
should work without throwing the above mentioned error

Additional info:
Comment 1 Junaid 2012-04-27 05:46:27 EDT
Saurabh,

I tried to reproduce the bug with the rpms at are due to be released with beta, the issue is not happening on them. Can you try it out on a different machine or restarting the memcached and swift servers.

For now moving to works for me. Reopen the bug if you find the issue once again.
Comment 2 Saurabh 2012-04-27 06:31:22 EDT
I tried the same stuff on a different setup altogether and it works, hence not pursuing this presently for further investigation.

Note You need to log in before you can comment on or make changes to this bug.