Bug 816216 - lvm dracut part removes VGs uncompromising
lvm dracut part removes VGs uncompromising
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike Burns
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 10:18 EDT by Fabian Deutsch
Modified: 2016-04-26 09:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 07:48:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-04-25 10:18:59 EDT
Description of problem:
The node dracut module is removing all VGs even if not all member PVs are given in the storage_init parameter

Version-Release number of selected component (if applicable):
6.3 snap 1

How reproducible:
always

Steps to Reproduce:
1. Prepare: 2 PVs (e.g. vda & vdb) in one VG with 3 LVs
2. Install node with the parameters: BOOTIF=link storage_init=/dev/vda firstboot adminpw=...
  
Actual results:
Installs without failure.

Expected results:
Install fails because vdb is not given in the storage init parameter.

Additional info:
Comment 1 Mike Burns 2012-07-17 09:10:27 EDT
http://gerrit.ovirt.org/#/c/5756/

Note You need to log in before you can comment on or make changes to this bug.