Bug 816222 - Coolkey changes Smart Card values as seen in the Smart Card manager on a SPICE guest.
Coolkey changes Smart Card values as seen in the Smart Card manager on a SPIC...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcacard (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 10:34 EDT by Bill Sanford
Modified: 2012-04-30 14:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 14:05:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-04-25 10:34:26 EDT
Description of problem:
The Smart Card manager on a SPICE guest reports different values when you "View Diagnostics" than on the host.

Both of the "View Diagnostics" are here:
http://pastebin.test.redhat.com/86482

Version-Release number of selected component (if applicable):
coolkey-1.1.0-20.el6

How reproducible:
100%

Steps to Reproduce:
1. Insert Smart card on RHEL 6.3 and "View Diagnostics" within the Smart Card Manager.
2. Start SPICE client and then the Smart Card Manager. 
3. Click the "View Diagnostics."
  
Actual results:
Some values are not the same and some are blank.

Expected results:
All of the values should be a pass-through to the SPICE client Smart Card Manager.

Additional info:

The basis for any Smart Card to work are the URLs on it, especially the phone home URL. In the SPICE client Smart Card Manager, all of the URLs are blank.

Phone Home URL: 
Smart Card Server URL: 
Enrollment UI URL:
Comment 1 Alon Levy 2012-04-30 10:06:46 EDT
Isn't this a problem with libcacard and not with coolkey?
Comment 2 Bob Relyea 2012-04-30 14:02:27 EDT
The effect is from libcacard, but it's not a bug. It's working as expected.

The card in question is a coolkey card, not a cac card, so it's not surprising that it has the fields are different, any more than one would expect a virtual mouse to have the same fields as the physical mouse.

If someone wants to emulate coolkey cards as well as cac cards, then that is an enhancement request for spice (and certainly not something to try to get into RHEL 6.3;).

bob
Comment 3 RHEL Product and Program Management 2012-04-30 14:05:09 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.