Bug 816224 - cluster-sync-to-store needs --riccipassword option
cluster-sync-to-store needs --riccipassword option
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
All Linux
medium Severity medium
: 2.2
: ---
Assigned To: Robert Rati
Tomas Rusnak
done
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 10:38 EDT by Robert Rati
Modified: 2012-09-25 04:45 EDT (History)
5 users (show)

See Also:
Fixed In Version: condor-7.6.5-0.15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 14:26:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2012-04-25 10:38:37 EDT
Description of problem:
The cluster-sync-to-store command needs to the --riccipassword option.  Otherwise the user is prompted for passwords.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2012-04-25 13:08:50 EDT
Since the cluster-* commands use ccs to access the cluster configuration and activate changes, all commands need to be able to provide the --riccipassword option or else the user will be prompted for a password.  The cluster-sync-to-store command didn't have the option, so when it was run after a configuration from luci the user would be prompted for localhost and other host passwords.

The cluster-sync-to-store command now has the --riccipassword option.

Tracking upstream on:
V7_6-branch
Comment 5 Tomas Rusnak 2012-06-20 09:23:49 EDT
# wallaby cluster-sync-to-store --riccipassword test
Console Connection Established...
...
#

# wallaby cluster-sync-to-store -h
Usage: cluster-sync-to-store 
    -h, --help                       displays this message
        --riccipassword PASS         The ricci user password

Help updated.

>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.