Bug 816240 - REST API only supports admin-login. user-login is missing.
REST API only supports admin-login. user-login is missing.
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-api (Show other bugs)
unspecified
Unspecified Linux
high Severity high
: ---
: 3.3.4
Assigned To: Asaf Shakarchi
infra
: FutureFeature
Depends On:
Blocks: 848379
  Show dependency treegraph
 
Reported: 2012-04-25 11:21 EDT by Pieter Vogel
Modified: 2014-07-20 02:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 848379 (view as bug list)
Environment:
Last Closed: 2012-07-01 03:12:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pieter Vogel 2012-04-25 11:21:15 EDT
Description of problem:
try to give a vdi-user a desktop from a pool via the REST-API. This is not possible because a login is always done as admin-login so users are not allowed.

We build our own portal (so we don't need firefox and can start spice from a very small pxe-booted environment) but a login with a rhevm-user account via the REST_API tries to give you an admin-login which is off course not allowed for a normal user. 


Version-Release number of selected component (if applicable):
rhel-62 rhev3.0

How reproducible:
always

Steps to Reproduce:
1. try a user-login via the REST-API
Comment 1 Michael Pasternak 2012-07-01 03:12:50 EDT
we will have this feature in 3.1

Note You need to log in before you can comment on or make changes to this bug.