Bug 816241 - Handle disconnections exposed by spice-gtk
Handle disconnections exposed by spice-gtk
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: beta
: 6.4
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On: 816231
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 11:27 EDT by David Jaša
Modified: 2012-07-27 04:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 04:08:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-04-25 11:27:56 EDT
Description of problem:
Handle disconnections exposed by spice-gtk. See the blocking bug for details.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Jaša 2012-04-25 11:35:50 EDT
Maybe a bit more info would be helpful. So in remote-viewer mode, an error pop-up should be created saying what went wrong. 

I'm not really sure what should happen when in virt-viewer mode (imagine one virt-viewer running, another one connecting to the same VM and stealing its desktop, first one detecting disconnect and thus reconnecting and taking display back and so forth...).
Comment 2 Daniel Berrange 2012-04-25 11:42:34 EDT
I don't really see that there is anything that needs doing here. virt-viewer  & remote-viewer already handles guest disconnect messages from spice-gtk. By default they will exit unless the --reconnect flag was given, in which case they try to reconnect to the desktop
Comment 3 RHEL Product and Program Management 2012-07-10 04:49:49 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 22:01:12 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 Daniel Berrange 2012-07-26 13:32:36 EDT
Please provide more info on why current behaviour is wrong as per comment #2
Comment 6 David Jaša 2012-07-27 04:08:18 EDT
Seen with from a bit of distance, it looks like proposed changes solve the problem of tcp stream disruption only partialy if there is no heartbeat in spice protocol, so closing it myself as wontfix...

Note You need to log in before you can comment on or make changes to this bug.