Bug 816247 - RHHAv2 needs to handle custom names from luci better
RHHAv2 needs to handle custom names from luci better
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
All Linux
medium Severity medium
: 2.2
: ---
Assigned To: Robert Rati
Tomas Rusnak
done
:
Depends On:
Blocks: 751870
  Show dependency treegraph
 
Reported: 2012-04-25 11:45 EDT by Robert Rati
Modified: 2012-09-25 04:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: condor-7.6.5-0.15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 14:26:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2012-04-25 11:45:03 EDT
Description of problem:
The cluster-* commands auto-generate names when used from the command line.  But cluster-sync-to-store needs to be able to handle a non-auto generated name, which occurs when a user uses luci/conga to configure the service.  Currently, the tools take the custom name and append some bits used during auto generation which results in the QS/JS failing to start.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2012-04-25 13:06:37 EDT
The cluster-sync-to-store command would take a name provided in the cluster.conf and append name information for the JS/QS.  This would result in the QS/JS not starting because the config would be wrong and no SPOOL would be defined.

Now, the tools only auto-generate a name if the JS/QS is added on the command line.  The cluster-sync-to-store command will use whatever names are in the cluster.conf file.

Tracking upstream on:
V7_6-branch
Comment 4 Tomas Rusnak 2012-06-28 07:25:46 EDT
Custom names added by luci. Wallaby cluster-sync-to-store created following configuration:

# condor_configure_pool -n `hostname` -l -v | grep -i spool
  JOB_SERVER.ha_jobserver2.SPOOL = $(SCHEDD.ha_schedd2.SPOOL)
  SCHEDD.ha_schedd3.HISTORY = $(SCHEDD.ha_schedd3.SPOOL)/history
  SCHEDD.ha_schedd1.HISTORY = $(SCHEDD.ha_schedd1.SPOOL)/history
  JOB_SERVER.ha_jobserver3.HISTORY = $(JOB_SERVER.ha_jobserver3.SPOOL)/history
  SCHEDD.ha_schedd2.SPOOL = /mnt/ha2
  QUERY_SERVER.ha_query3.SPOOL = $(SCHEDD.ha_schedd3.SPOOL)
  QUERY_SERVER.ha_query2.SPOOL = $(SCHEDD.ha_schedd2.SPOOL)
  JOB_SERVER.ha_jobserver1.HISTORY = $(JOB_SERVER.ha_jobserver1.SPOOL)/history
  QUERY_SERVER.ha_query1.SPOOL = $(SCHEDD.ha_schedd1.SPOOL)
  QUERY_SERVER.ha_query1.HISTORY = $(QUERY_SERVER.ha_query1.SPOOL)/history
  SCHEDD.ha_schedd3.SPOOL = /mnt/ha3
  QUERY_SERVER.ha_query3.HISTORY = $(QUERY_SERVER.ha_query3.SPOOL)/history
  JOB_SERVER.ha_jobserver3.SPOOL = $(SCHEDD.ha_schedd3.SPOOL)
  SCHEDD.ha_schedd2.HISTORY = $(SCHEDD.ha_schedd2.SPOOL)/history
  QUERY_SERVER.ha_query2.HISTORY = $(QUERY_SERVER.ha_query2.SPOOL)/history
  JOB_SERVER.ha_jobserver1.SPOOL = $(SCHEDD.ha_schedd1.SPOOL)
  JOB_SERVER.ha_jobserver2.HISTORY = $(JOB_SERVER.ha_jobserver2.SPOOL)/history
  SCHEDD.ha_schedd1.SPOOL = /mnt/ha1

Custom names from cluster.conf stay untouched in the configuration. JS/QS were started correctly:

# ps ax | grep condor 
 1726 ?        Ssl    0:20 condor_master -pidfile /var/run/condor/condor_master.pid
 1746 ?        Ssl    0:15 condor_collector -f
 1749 ?        Ssl    0:07 condor_startd -f
 1750 ?        Ssl    0:14 condor_negotiator -f
 1751 ?        Ssl    0:59 /usr/bin/python /usr/sbin/condor_configd
 6184 ?        S<l    0:00 condor_schedd -pidfile /var/run/condor/condor_schedd-ha_schedd1.pid -local-name ha_schedd1
 6196 ?        S<     0:00 condor_procd -A /var/run/condor/procd_pipe.ha_schedd1.SCHEDD -R 10000000 -S 60 -C 64
 6226 ?        S<l    0:00 condor_job_server -pidfile /var/run/condor/condor_job_server-ha_jobserver1.pid -local-name ha_jobserver1
 6282 ?        S<     0:00 aviary_query_server -pidfile /var/run/condor/aviary_query_server-ha_query1.pid -local-name ha_query1
 6302 pts/0    S+     0:00 grep condor


>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.