Bug 816252 - Unreadable russian mans for some topics
Unreadable russian mans for some topics
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.2
All Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jan Chaloupka
Iveta Wiedermann
: ManPageChange
Depends On:
Blocks: 1119295
  Show dependency treegraph
 
Reported: 2012-04-25 12:00 EDT by Vladimir Titov
Modified: 2014-10-14 03:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: man-pages-overrides-6.6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: many russian man page were unreadable Consequence: unreadable man pages Fix: re-encoding of man pages deleted Result: man pages are now readable
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:25:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-13 21:21:54 EDT

  None (edit)
Description Vladimir Titov 2012-04-25 12:00:10 EDT
Description of problem:
Unreadable russian manual pages

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. LC_ALL=ru_RU.UTF8 man accept (and 82 mans else)
2. or LC_ALL=ru_RU.UTF8 ma -M /usr/share/man/ru man accept
3.
  
Actual results: Wrong character set (not cyrillic)


Expected results: Cyrillic manual


Additional info: Needless conversion (from koi8 to utf8) of manuals in
man-pages-ru_3.24-2059-1223-20100508.
Comment 2 RHEL Product and Program Management 2012-09-07 01:29:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Jan Chaloupka 2014-06-10 08:01:31 EDT
========gibberish========
man1:
intro.1.gz ldd.1.gz time.1.gz

man2:
accept.2.gz accept4.2.gz access.2.gz acct.2.gz add_key.2.gz adjtimex.2.gz alarm.2.gz alloc_hugepages.2.gz arch_prctl.2.gz bdflush.2.gz bind.2.gz brk.2.gz capget.2.gz capset.2.gz chdir.2.gz chroot.2.gz close.2.gz execve.2.gz exit_group.2.gz fchdir.2.gz free_hugepages.2.gz intro.2.gz ioctl_list.2.gz mkdir.2.gz mknod.2.gz nfsservctl.2.gz pause.2.gz read.2.gz rmdir.2.gz sbrk.2.gz symlink.2.gz sync.2.gz syscalls.2.gz time.2.gz vhangup.2.gz waidpid.2.gz wait.2.gz wait3.2.gz wait4.2.gz waitid.2.gz waitpid.2.gz write.2.gz

man3:
dladdr.3.gz dlclose.3.gz dlerror.3.gz dlopen.3.gz dlsym.3.gz dlvsym.3.gz intro.3.gz isatty.3.gz

man4:
intro.4.gz

man5:
acct.5.gz charmap.5.gz core.5.gz dir_colors.5.gz elf.5.gz filesystems.5.gz fs.5.gz ftpusers.5.gz group.5.gz host.conf.5.gz hosts.5.gz hosts.equiv.5.gz intro.5.gz issue.5.gz locale.5.gz motd.5.gz networks.5.gz nologin.5.gz nscd.conf.5.gz nsswitch.conf.5.gz passwd.5.gz proc.5.gz protocols.5.gz resolv.conf.5.gz resolver.5.gz rpc.5.gz securetty.5.gz services.5.gz shells.5.gz slabinfo.5.gz termcap.5.gz ttytype.5.gz tzfile.5.gz utmp.5.gz utmpx.5.gz wtmp.5.gz

man6:
intro.6.gz

man7:
armscii-8.7.gz intro.7.gz operator.7.gz

man8:
intro.8.gz ldconfig.8.gz nscd.8.gz sync.8.gz tzselect.8.gz zdump.8.gz zic.8.gz

========russian-english mix========
man1:
gpasswd.1.gz newgrp.1.gz sg.1.gz

man8:
adduser.8.gz chpasswd.8.gz groupadd.8.gz groupdel.8.gz groupmems.8.gz groupmod.8.gz grpck.8.gz newusers.8.gz pwck.8.gz useradd.8.gz userdel.8.gz usermod.8.gz

There can be more russian-english mix man pages. Some man pages can contain gibberish not spoted.
Comment 14 errata-xmlrpc 2014-10-14 03:25:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html

Note You need to log in before you can comment on or make changes to this bug.