This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 816328 - finger segfaults if pw->pw_gecos is NULL.
finger segfaults if pw->pw_gecos is NULL.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: finger (Show other bugs)
6.4
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Tomas Hozza
Martin Žember
: Patch
Depends On:
Blocks: 836169 947782
  Show dependency treegraph
 
Reported: 2012-04-25 15:49 EDT by Lars Kellogg-Stedman
Modified: 2015-07-13 00:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: finger-0.17-40.el6
Doc Type: Bug Fix
Doc Text:
When the "compat" method is specified in the nsswitch.conf file, special entries containing the "+" or "-" characters are allowed to be used in the /etc/passwd file. Previously, when the finger utility was run with a "username" argument on a host that had the special entries in /etc/passwd, finger terminated with a segmentation fault. With this update, the code that handles the "username" argument has been fixed to perform the necessary checks and the finger utility no longer crashes in the described scenario.
Story Points: ---
Clone Of:
: 866873 (view as bug list)
Environment:
Last Closed: 2014-06-02 03:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for this issue. (503 bytes, patch)
2012-10-16 06:28 EDT, Tomas Hozza
no flags Details | Diff

  None (edit)
Description Lars Kellogg-Stedman 2012-04-25 15:49:36 EDT
Description of problem:

We have a NIS-bound system with 'passwd: compat' in /etc/nsswitch.conf.  The final line in /etc/passwd on this was system was:

  +:

On this system, "finger" would segfault when passed a username as an
argument.  On line 188 in finger/util.c, finger was calling strncpy()
like this:

  int                         
  match(struct passwd *pw, const char *user)
  {                               
          char *p;                        
          int i, j, ct, rv=0;             
          char *rname;            
                          
          strncpy(tbuf, pw->pw_gecos, TBUFLEN);

With our /etc/passwd file configured as described, pw->pw_gecos would
have a NULL rather than empty value, causing strncpy() to segfault.
An ideal fix would be to have match() return 0 if pw->pw_gecos is
NULL, as in this patch:

diff --git a/finger/util.c b/finger/util.c
index 8e28d63..c82bc86 100644
--- a/finger/util.c
+++ b/finger/util.c
@@ -186,6 +186,9 @@ match(struct passwd *pw, const char *user)
        int i, j, ct, rv=0;
        char *rname;
 
+       if (pw->pw_gecos == NULL)
+               return 0;
+
        strncpy(tbuf, pw->pw_gecos, TBUFLEN);
        tbuf[TBUFLEN-1] = 0;  /* guarantee null termination */
        p = tbuf;
Comment 3 Lars Kellogg-Stedman 2012-10-11 09:02:30 EDT
Problem identified and patch provided...any updates on this issue?  Thanks!
Comment 4 Tomas Hozza 2012-10-16 06:28:11 EDT
Created attachment 628085 [details]
Patch for this issue.
Comment 13 Tomas Hozza 2014-03-27 04:58:40 EDT
(In reply to Lars Kellogg-Stedman from comment #3)
> Problem identified and patch provided...any updates on this issue?  Thanks!

Hi Lars.

If everything goes well, this issue will be fixed in the next RHEL-6 minor
update release.
Comment 16 errata-xmlrpc 2014-06-02 03:20:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0587.html

Note You need to log in before you can comment on or make changes to this bug.