Bug 816347 - On screenlock when the screen fades, pressing keys to prevent the lockout does not work
On screenlock when the screen fades, pressing keys to prevent the lockout doe...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: Regression
Depends On:
Blocks: 782183 842499
  Show dependency treegraph
 
Reported: 2012-04-25 16:39 EDT by Simo Sorce
Modified: 2013-03-21 04:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:03:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2012-04-25 16:39:42 EDT
In 6.2 you can press a key when you see the screen starting fading for an impending screenlock.
With the beta packages (1.10.6-1.el6.i686) this doesn't work, and you are left watching a quite slow fade until you are brought to a screensaver unlock screen.

The cause might be the fix for rhbz#748704
Comment 2 Tomas Pelka 2012-04-25 16:54:52 EDT
I can remember that I saw this behavior as well, but not any more right now. Just FYI.
Comment 4 Adam Jackson 2012-04-26 10:33:50 EDT
Simo tested a patch for me, and it appears to have worked.  Writing this down so I don't forget:

This is indeed caused by:

* Mon Mar 19 2012 Adam Jackson <ajax@redhat.com> 1.10.4-14
- xserver-1.10.4-sync-revert.patch: Revert an edge-case change in IDLETIME
  that appears to be more wrong than right. (#748704)

That patch reverts two hunks from Xext/sync.c.  Those hunks would be correct, if they swapped places.

I don't believe this bug to be a blocker, inability to interrupt the screensaver is merely cosmetic.
Comment 8 Adam Jackson 2012-09-12 12:33:05 EDT
Upstream fix for this was:

commit 4a6f42dda00ba3b5616f8a86f0d4c9a652c7d9d4
Author: Adam Jackson <ajax@redhat.com>
Date:   Mon Jul 23 16:34:28 2012 -0400

    sync: Fix logic error from b55bf248581dc66321b24b29f199f6dc8d02db1b

This change is included in xserver 1.13.0, current RHEL6.4 build is xorg-x11-server-1.13.0-1.el6.

MODIFIED
Comment 11 Ray Strode [halfline] 2012-12-14 14:36:03 EST
*** Bug 848016 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2013-02-21 03:03:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html

Note You need to log in before you can comment on or make changes to this bug.