Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 816489 - Bug::search XMLRPC call does not return Bug attributes
Summary: Bug::search XMLRPC call does not return Bug attributes
Keywords:
Status: CLOSED DUPLICATE of bug 816038
Alias: None
Product: Bugzilla
Classification: Community
Component: WebService
Version: 4.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: 4.2-1
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: BZ42
TreeView+ depends on / blocked
 
Reported: 2012-04-26 08:56 UTC by Martin Kosek
Modified: 2018-12-09 06:29 UTC (History)
1 user (show)

Fixed In Version: 4.2.1-0.b28
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-26 09:23:15 UTC


Attachments (Terms of Use)

Description Martin Kosek 2012-04-26 08:56:54 UTC
Description of problem:

When Bug::search is called with 'quicksearch' or 'savedsearch' option, the included bugs do not contain any attribute:

$ python
Python 2.7.2 (default, Oct 27 2011, 01:40:22) 
[GCC 4.6.1 20111003 (Red Hat 4.6.1-10)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> 
...
>>> proxy
<ServerProxy for partner-bugzilla.redhat.com/xmlrpc.cgi>
>>> proxy.Bug.search({'savedsearch':'mkosek: processed IPA bugs', 'include_fields': [ 'id', 'summary', 'status'], })
{'bugs': [{}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}]}
>>> 
>>> 
>>> proxy.Bug.search({'quicksearch':'product:"Red Hat Enterprise Linux 6" component:"ipa" flag:rhel-6.3.0+', 'include_fields': [ 'id', 'summary', 'status']})
{'bugs': [{}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}, {}]}


Version-Release number of selected component (if applicable):
4.2.1-0.b27

How reproducible:


Steps to Reproduce:
1. Call Bug::search XMLRPC call with 'quicksearch' or 'savedsearch' option
2.
3.
  
Actual results:
Empty bug records are returned

Expected results:
Bug records with bug attributes are returned

Additional info:
Bug attributes were returned for standard XMLRPC Bug::search query

Comment 1 Simon Green 2012-04-26 09:23:15 UTC

*** This bug has been marked as a duplicate of bug 816038 ***

Comment 2 Martin Kosek 2012-04-26 12:59:04 UTC
Simon, are you sure this is a duplicate of Bug 816038? In this case, I passed the list of fields and the result was still empty bug record.

Comment 3 Simon Green 2012-04-26 21:51:33 UTC
(In reply to comment #2)
> Simon, are you sure this is a duplicate of Bug 816038? In this case, I passed
> the list of fields and the result was still empty bug record.

Yes, I'm 99% sure. v4.2.1-0.b38 wasn't release until 2:02pm UTC (just over an hour after your last comment), which would explain why you were still seeing the bad result.

If you are still seeing the bad result, please reopen this bug.

  -- simon

Comment 4 Martin Kosek 2012-04-27 11:01:09 UTC
Calls without include_fields now return filled bugs, but there are other issues -> Bug 816953.


Note You need to log in before you can comment on or make changes to this bug.