Bug 816509 - 'Updates' notification not showing up in Gnome (F17 TC1)
'Updates' notification not showing up in Gnome (F17 TC1)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-04-26 05:57 EDT by Josef Skladanka
Modified: 2012-05-07 22:08 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 22:08:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josef Skladanka 2012-04-26 05:57:21 EDT
Description of problem:
Even though there are updates available, no notification is shown. I've tried both waiting for a long time, and changing the updates-check frequency by

$ gsettings set org.gnome.settings-daemon.plugins.updates last-updates-notification 42
$ gsettings set org.gnome.settings-daemon.plugins.updates frequency-get-updates 600

as described in https://fedoraproject.org/wiki/QA:Testcase_desktop_updates

Steps to Reproduce:
1. Install fresh F17 TC1
2. Wait infinitely ;)

Expected results:

'New updates available' notification is shown.
Comment 1 Petr Schindler 2012-04-27 02:47:15 EDT
I also reproduced this bug. I have set frequency with gsettings and it still doesn't show up.

I propose this bug as final blocker per final criterion:
The default update manager in release-blocking desktops must not periodically check for updates when the system is booted live, but must periodically check for updates when running on an installed system
Comment 2 Timothy Davis 2012-05-01 13:38:08 EDT
Fedora 17-TC2 x86_64 Gnome 3.4
Updated from F17-Beta
Compaq 6910p Core2Duo
Ran updates yesterday from CLI, today didn't run update and ran "Update software" and found 50 updates, no notifications in the system tray
Comment 3 Tim Flink 2012-05-01 17:34:55 EDT
Discussed in the 2012-05-01 blocker bug review meeting. Accepted as a Fedora 16 final blocker as it violates the following beta release criterion [1]:

The default update manager in release-blocking desktops must not periodically check for updates when the system is booted live, but must periodically check for updates when running on an installed system

[1] https://fedoraproject.org/wiki/Fedora_17_Beta_Release_Criteria
Comment 4 Tim Flink 2012-05-01 17:41:31 EDT
(In reply to comment #3)
> Discussed in the 2012-05-01 blocker bug review meeting. Accepted as a Fedora 16
> final blocker as it violates the following beta release criterion [1]:

Whoops, used an old template - I meant Fedora 17
Comment 5 Matthias Clasen 2012-05-04 00:10:17 EDT
Looking at the settings we have,

frequency-get-updates 86400 How often to check for updates
frequency-updates-notification 604800 How often to notify the user that non-critical updates are available

We check for updates once a day, and notify only once per week for non-critical updates
Comment 6 Richard Hughes 2012-05-04 05:09:51 EDT
(In reply to comment #5)
> We check for updates once a day, and notify only once per week for non-critical
> updates

Correct. I spoke with Adam about the procedure to test this properly about two weeks ago. QA:Testcase_desktop_updates needs to be updated to change frequency-updates-notification too.

Richard.
Comment 7 Petr Schindler 2012-05-04 06:59:31 EDT
I changed frequency-updates-notification to 900 and it didn't helped. System still didn't show notification even when I wait for one hour.

I agree that we should amend test case.
Comment 8 Petr Schindler 2012-05-04 08:51:57 EDT
It works for me with updates from updates testing. I set reasonable frequency time and I got notification.
Comment 9 Adam Williamson 2012-05-04 18:10:57 EDT
petr: you have to log out and log back in after changing the frequency-updates-notification setting, we think. and it's all a bit 'temperamental'. so I suspect updates-testing doesn't have much to do with it, and it was more to do with rebooting or restarting the session after you installed the updates.

I think if we just amend the test case, that'll be fine; I don't think this is actually broken.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2012-05-04 18:13:34 EDT
I've amended the test case, I think it's okay now. We should re-test with TC2 and no updates to be sure.
Comment 11 Adam Williamson 2012-05-07 22:08:27 EDT
I just tested with TC3. The other factor to take into account is that the silent automatic security updating monkeys with things.

I did a clean TC3 install, booted, set all three keys, and waited.

I left it up for 24 minutes, watching htop, and saw a packagekitd and yumBackEnd process hanging around, seemingly not doing much. Nothing got installed.

I got bored, booted to runlevel 3, installed htop and jnettop, and rebooted. I watched with htop and jnettop. I saw it, quite slowly, download the available security updates (including a kernel) and install them. That took about 10 minutes.

Once it was done I verified the transaction with 'yum history' and waited another 10 minutes or so. No further update check seemed to happen. I could probably have waited a bit longer, though.

I rebooted, and after about five minutes, got an update notification.

So I got the notification on the third boot. On the second, the auto-security update happened. On the first...I'm not sure if it was trying to do the auto-security update and  being really slow about it, or just nothing. But it does seem the update notification ultimately works, so I think we can close this bug. I'll update the test case again to advise more patience. :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.