This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 816522 - grub menu entry editor confused by tabs in config
grub menu entry editor confused by tabs in config
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17-accepted/F17FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-04-26 06:26 EDT by Michal Schmidt
Modified: 2012-04-30 19:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-30 19:10:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-04-26 06:26:00 EDT
Description of problem:
It appears that the GRUB menu gets confused by tab characters in the config. Long lines overflow the editing box and it is very difficult to edit the entries, because the cursor position appears in places inconsistent with the text edited.

Version-Release number of selected component (if applicable):
grub2-1.99-19.fc17

How reproducible:
always

Steps to Reproduce:
1. Make sure you are actually using the current GRUB version: grub2-install /dev/vda
2. Reboot
3. Press 'e' in the GRUB menu.
4. Use the cursor keys, try to get to the end of a line. Try editing something.
  
Actual results:
You won't reach the visible end of the line.
When you start typing something, you're actually editing text that does not lie exactly at the place where the cursor appears.

Expected results:
Consistently usable menu editor.

Additional info:
This may present a difficulty for debugging boot problems. We often need people to edit their kernel command line.
Fixing this post-release may be a problem, because AFAIK updating the grub2 package does not actually cause the new version to be used for the next boots.

I built grub2-2.0-0.23 from Fedora git and it seems to be fixed there. Can we get it into F17?
Comment 1 Michal Schmidt 2012-04-26 06:30:12 EDT
I forgot to mention that it affects the default installation. No configuration changes are necessary to reproduce the bug.
Comment 2 Mads Kiilerich 2012-04-30 19:10:06 EDT
grub2-2.0-0.24.beta4.fc17 has been pushed to f17 stable - closing

Note You need to log in before you can comment on or make changes to this bug.