Bug 816536 - biosdevname enabled still shows eth* naming on second port of Mellanox 10GbE cards
Summary: biosdevname enabled still shows eth* naming on second port of Mellanox 10GbE ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: biosdevname
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Narendra K
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 815724
TreeView+ depends on / blocked
 
Reported: 2012-04-26 10:48 UTC by Harald Hoyer
Modified: 2018-11-30 22:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-26 22:32:36 UTC


Attachments (Terms of Use)
New biosdevname for mellanox/chelsio card (197.01 KB, application/gzip)
2012-05-01 19:26 UTC, jordan hargrave
no flags Details
'biosdevname --policy physical -d' output from a host with a Chelsio T3 and a Mellanox ConnectX-3 (2.01 KB, text/plain)
2012-05-02 15:43 UTC, Robert Kennedy
no flags Details
lspci, dmidecode, and biosdevname output for a Chelsio T4 (477.67 KB, text/plain)
2012-05-03 19:53 UTC, Robert Kennedy
no flags Details
New biosdevname for fixing chelsio T4 (831.75 KB, application/x-gzip)
2012-05-08 18:58 UTC, jordan hargrave
no flags Details
T3 and CX2 in one host, T4 and CX3 in another (lspci, dmidecode, and biosdevname) (47.47 KB, application/x-gzip)
2012-05-09 12:14 UTC, Robert Kennedy
no flags Details
New test biosdevname (1.54 MB, application/x-tar)
2012-05-11 15:07 UTC, jordan hargrave
no flags Details
T3 and CX2 in one host, T4 and CX3 in another (lspci, dmidecode, and biosdevname) (48.25 KB, application/x-gzip)
2012-05-14 12:17 UTC, Robert Kennedy
no flags Details
new test case biosdevname (830.40 KB, application/x-compressed-tar)
2012-06-07 21:23 UTC, jordan hargrave
no flags Details
new test biosdevname x2 (862.25 KB, application/x-compressed-tar)
2012-06-11 21:30 UTC, jordan hargrave
no flags Details

Description Harald Hoyer 2012-04-26 10:48:39 UTC
Public clone of RHEL6.2 bug 815724 with biosdevname.

Description of problem:

With biosdevname enabled, the second port of Mellanox 10GbE network cards still
use eth interface names on second port of cards. This was seen on HP DL380 G7
with 4 onboard 1GbE NICs and two dual port Mellanox 10GbE cards. All other
interfaces used the expected biosdevname convention.


Version-Release number of selected component (if applicable):
RHEL 6.2, biosdevname-0.3.11-1.el6.x86_64 

How reproducible:
The customer can reproduce this with a kickstart every time.

Steps to Reproduce:
1. Specify biosdevname=1 command line parameter to the kickstart build.
2. Install RHEL 6.2 through kickstart
3. Observe that the second port on each Mellanox card is eth[1,3], not p2p2,
p3p2 as expected.

Actual results:
The second port on each Mellanox card is eth[1,3]

# ethtool -i eth3
driver: mlx4_en
version: 1.5.4.1 (March 2011)
firmware-version: 2.8.600
bus-info: 0000:0e:00.0
#
# biosdevname -i eth3
# echo $?
2

Expected results:
Those ports should be p2p2, p3p2 as per the biosdevname convention.

Comment 1 Harald Hoyer 2012-04-27 10:31:56 UTC
# biosdevname -d
BIOS device: p3p1
Kernel name: p3p1
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.8.600
Bus Info: 0000:0e:00.0
PCI name      : 0000:0e:00.0
PCI Slot      : 3
SMBIOS Label: PCI-E Slot 3
Index in slot: 1

BIOS device:
Kernel name: p3p2
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.8.600
Bus Info: 0000:0e:00.0
#

Comment 2 jordan hargrave 2012-05-01 19:26:58 UTC
Created attachment 581452 [details]
New biosdevname for mellanox/chelsio card

Please try this version of biosdevname and see if it works on your cards

Comment 3 Harald Hoyer 2012-05-02 15:08:42 UTC
(In reply to comment #2)
> Created attachment 581452 [details]
> New biosdevname for mellanox/chelsio card
> 
> Please try this version of biosdevname and see if it works on your cards

will test

Comment 4 Robert Kennedy 2012-05-02 15:43:09 UTC
Created attachment 581651 [details]
'biosdevname --policy physical -d' output from a host with a Chelsio T3 and a Mellanox ConnectX-3

Works for me. I've attached the output from the new biosdevname on a host with both cards in it.

Comment 5 jordan hargrave 2012-05-02 19:54:48 UTC
Great, thanks!

Comment 6 Narendra K 2012-05-03 14:17:24 UTC
(In reply to comment #4)
> Created attachment 581651 [details]
> 'biosdevname --policy physical -d' output from a host with a Chelsio T3 and a
> Mellanox ConnectX-3
> 
> Works for me. I've attached the output from the new biosdevname on a host with
> both cards in it.

Hi Robert, it would be great if this can be tested on a embedded device which has a single PCI device, but has 2 ports. I suppose the adapters tested are add-in adapters. Are these adapters available embedded (lan-on-motherboard) form ?

Comment 7 Robert Kennedy 2012-05-03 14:27:45 UTC
Yes, these were add-in PCI cards. I don't know of any manfuacturers shipping either of these chips as embedded. The new sandy bridge servers from Dell offer some form of swappable l-o-m but I believe the only choices so far are the Broadcom mumblemumble and the Intel i350.

I tested the patched biosdevname against an add-in Chelsio T4 and it almost works. It marks port 1 as p5. As you can see, udev also missed the ordering (assuming lowest to highest MAC address ordering is desired).

BIOS device: p1p5
Kernel name: eth7
Permanent MAC: 00:07:43:10:52:B0
Assigned MAC : 00:07:43:10:52:B0
ifIndex: 6
Driver: cxgb4
Driver version: 1.3.0-ko
Firmware version: 1.3.10.0, TP 0.1.7.0
Bus Info: 0000:04:00.4
PCI name      : 0000:04:00.4
PCI Slot      : 1
SMBIOS Label: PCI1
Index in slot: 5

BIOS device: p1p2
Kernel name: eth6
Permanent MAC: 00:07:43:10:52:B8
Assigned MAC : 00:07:43:10:52:B8
ifIndex: 7
Driver: cxgb4
Driver version: 1.3.0-ko
Firmware version: 1.3.10.0, TP 0.1.7.0
Bus Info: 0000:04:00.4
PCI name      : 0000:04:00.4
PCI Slot      : 1
SMBIOS Label: PCI1
Index in slot: 5

Comment 8 jordan hargrave 2012-05-03 19:16:05 UTC
Can you attach full output of lspci -vvvxxxx and dmidecode ?

Comment 9 jordan hargrave 2012-05-03 19:16:49 UTC
also full output of biosdevname -d

Comment 10 Robert Kennedy 2012-05-03 19:53:00 UTC
Created attachment 581951 [details]
lspci, dmidecode, and biosdevname output for a Chelsio T4

Attached requested information. If this Chelsio card information is cluttering this ticket about Mellanox, feel free to move it over to bug 756164.

Comment 11 jordan hargrave 2012-05-08 18:58:15 UTC
Created attachment 583058 [details]
New biosdevname for fixing chelsio T4

Try this version on the T4 card (and retry on Mellanox)

Comment 12 Robert Kennedy 2012-05-09 12:14:30 UTC
Created attachment 583255 [details]
T3 and CX2 in one host, T4 and CX3 in another (lspci, dmidecode, and biosdevname)

Looks like it didn't fix the T4 issue (it's still p1p5/p1p2) and caused some problems with the Mellanox CX2, which was working with the previous version (it's now reporting p2p0/p2p2).

Comment 13 jordan hargrave 2012-05-09 15:25:21 UTC
Grr..

Comment 14 Harald Hoyer 2012-05-10 10:04:29 UTC
hmm, we have a customer, who tried the biosdevname version of comment #2

It still doesn't seem to work :-/

BIOS device: p3p1
Kernel name: p3p1
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.8.600
Bus Info: 0000:0e:00.0
PCI name      : 0000:0e:00.0
PCI Slot      : 3
SMBIOS Label: PCI-E Slot 3
Index in slot: 1

BIOS device:
Kernel name: eth3
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.8.600
Bus Info: 0000:0e:00.0

Comment 15 jordan hargrave 2012-05-11 07:20:40 UTC
Harold, Are you sure you tried the right version? There should be an 'ifIndex' entry if using the correct one.

Comment 16 jordan hargrave 2012-05-11 15:07:06 UTC
Created attachment 583864 [details]
New test biosdevname

Can you test this version and send the output?

Comment 17 Robert Kennedy 2012-05-14 12:17:20 UTC
Created attachment 584350 [details]
T3 and CX2 in one host, T4 and CX3 in another (lspci, dmidecode, and biosdevname)

Updated attachment with the output(s) of the more debugified biosdevname.

Comment 18 Harald Hoyer 2012-05-22 15:24:18 UTC
with biosdevname-0.4.0 first card is correct, but second gets eth3 instead of p3p2


BIOS device: p2p1
Kernel name: p2p1
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 6
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0b:00.0
PCI name      : 0000:0b:00.0
PCI Slot      : 2
SMBIOS Label: PCI-E Slot 2
Index in slot: 1
 
BIOS device: p2p2
Kernel name: p2p2
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 7
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0b:00.0
PCI name      : 0000:0b:00.0
PCI Slot      : 2
SMBIOS Label: PCI-E Slot 2
Index in slot: 1
 
BIOS device: p3p1
Kernel name: p3p1
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 8
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0e:00.0
PCI name      : 0000:0e:00.0
PCI Slot      : 3
SMBIOS Label: PCI-E Slot 3
Index in slot: 1
 
BIOS device: p3p2
Kernel name: eth3
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 9
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0e:00.0
PCI name      : 0000:0e:00.0
PCI Slot      : 3
SMBIOS Label: PCI-E Slot 3
Index in slot: 1


any hint?

Comment 19 Harald Hoyer 2012-05-29 11:04:22 UTC
ok, here is the debug version:

# biosdevname -d
slot: 00:00.0   old:2147483647 new:2147483647
slot: 00:01.0   old:2147483647 new:2147483647
slot: 05:00.0   old:2147483647 new:2147483647  **
slot: 00:02.0   old:2147483647 new:2147483647
slot: 00:03.0   old:2147483647 new:2147483647
slot: 00:04.0   old:2147483647 new:2147483647
slot: 00:05.0   old:2147483647 new:2147483647
slot: 00:06.0   old:2147483647 new:2147483647
slot: 00:07.0   old:2147483647 new:2147483647
slot: 00:08.0   old:2147483647 new:2147483647
slot: 00:09.0   old:2147483647 new:2147483647
slot: 00:0a.0   old:2147483647 new:2147483647
slot: 00:0d.0   old:2147483647 new:2147483647
slot: 00:0d.1   old:2147483647 new:2147483647
slot: 00:0d.2   old:2147483647 new:2147483647
slot: 00:0d.3   old:2147483647 new:2147483647
slot: 00:0d.4   old:2147483647 new:2147483647
slot: 00:0d.5   old:2147483647 new:2147483647
slot: 00:0d.6   old:2147483647 new:2147483647
slot: 00:0e.0   old:2147483647 new:2147483647
slot: 00:0e.1   old:2147483647 new:2147483647
slot: 00:0e.2   old:2147483647 new:2147483647
slot: 00:0e.3   old:2147483647 new:2147483647
slot: 00:0e.4   old:2147483647 new:2147483647
slot: 00:14.0   old:2147483647 new:2147483647
slot: 00:14.1   old:2147483647 new:2147483647
slot: 00:14.2   old:2147483647 new:2147483647
slot: 00:1c.0   old:2147483647 new:2147483647
slot: 03:00.0   old:0 new:0  **  net
slot: 03:00.1   old:0 new:0  **  net
slot: 00:1c.2   old:2147483647 new:2147483647
slot: 04:00.0   old:0 new:0  **  net
slot: 04:00.1   old:0 new:0  **  net
slot: 00:1c.4   old:2147483647 new:2147483647
slot: 02:00.0   old:2147483647 new:2147483647  **
slot: 02:00.2   old:2147483647 new:2147483647  **
slot: 02:00.4   old:2147483647 new:2147483647  **
slot: 00:1d.0   old:2147483647 new:2147483647
slot: 00:1d.1   old:2147483647 new:2147483647
slot: 00:1d.2   old:2147483647 new:2147483647
slot: 00:1d.3   old:2147483647 new:2147483647
slot: 00:1d.7   old:2147483647 new:2147483647
slot: 00:1e.0   old:2147483647 new:2147483647
slot: 01:03.0   old:2147483647 new:2147483647  **
slot: 00:1f.0   old:2147483647 new:2147483647
slot: 01:03.0   old:2147483647 new:2147483647
slot: 02:00.0   old:2147483647 new:2147483647
slot: 02:00.2   old:2147483647 new:2147483647
slot: 02:00.4   old:2147483647 new:2147483647
slot: 03:00.0   old:0 new:0   net
adding slot: 0
 setting embedded index: 1
slot: 03:00.1   old:0 new:0   net
found slot: 0 1
 setting embedded index: 2
slot: 04:00.0   old:0 new:0   net
found slot: 0 2
 setting embedded index: 3
slot: 04:00.1   old:0 new:0   net
found slot: 0 3
 setting embedded index: 4
slot: 05:00.0   old:2147483647 new:2147483647
slot: 08:00.0   old:1 new:1
slot: 0b:00.0   old:2 new:2   net
adding slot: 2
 setting index_in_slot : 1
slot: 0e:00.0   old:3 new:3   net
adding slot: 3
 setting index_in_slot : 1
BIOS device: em1
Kernel name: em1
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 2
Driver: bnx2
Driver version: 2.1.11
Firmware version: bc 5.2.3 NCSI 2.0.12
Bus Info: 0000:03:00.0
PCI name      : 0000:03:00.0
PCI Slot      : embedded
Embedded Index: 1

BIOS device: em2
Kernel name: em2
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 3
Driver: bnx2
Driver version: 2.1.11
Firmware version: bc 5.2.3 NCSI 2.0.12
Bus Info: 0000:03:00.1
PCI name      : 0000:03:00.1
PCI Slot      : embedded
Embedded Index: 2

BIOS device: em3
Kernel name: em3
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 4
Driver: bnx2
Driver version: 2.1.11
Firmware version: bc 5.2.3
Bus Info: 0000:04:00.0
PCI name      : 0000:04:00.0
PCI Slot      : embedded
Embedded Index: 3

BIOS device: em4
Kernel name: em4
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 5
Driver: bnx2
Driver version: 2.1.11
Firmware version: bc 5.2.3
Bus Info: 0000:04:00.1
PCI name      : 0000:04:00.1
PCI Slot      : embedded
Embedded Index: 4

BIOS device: p2p1
Kernel name: p2p1
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 6
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0b:00.0
PCI name      : 0000:0b:00.0
PCI Slot      : 2
SMBIOS Label: PCI-E Slot 2
Index in slot: 1

BIOS device: p2p2
Kernel name: p2p2
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 7
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0b:00.0
PCI name      : 0000:0b:00.0
PCI Slot      : 2
SMBIOS Label: PCI-E Slot 2
Index in slot: 1

BIOS device: p3p1
Kernel name: p3p1
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 8
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0e:00.0
PCI name      : 0000:0e:00.0
PCI Slot      : 3
SMBIOS Label: PCI-E Slot 3
Index in slot: 1

BIOS device: p3p2
Kernel name: eth3
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
ifIndex: 9
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.9.1200
Bus Info: 0000:0e:00.0
PCI name      : 0000:0e:00.0
PCI Slot      : 3
SMBIOS Label: PCI-E Slot 3
Index in slot: 1

Comment 20 Narendra K 2012-05-31 12:58:52 UTC
(In reply to comment #19)
> ok, here is the debug version:
> 
> # biosdevname -d
> slot: 00:00.0   old:2147483647 new:2147483647
> slot: 00:01.0   old:2147483647 new:2147483647
> slot: 05:00.0   old:2147483647 new:2147483647  **
> slot: 00:02.0   old:2147483647 new:2147483647
> slot: 00:03.0   old:2147483647 new:2147483647
> slot: 00:04.0   old:2147483647 new:2147483647
> slot: 00:05.0   old:2147483647 new:2147483647
> slot: 00:06.0   old:2147483647 new:2147483647
> slot: 00:07.0   old:2147483647 new:2147483647
> slot: 00:08.0   old:2147483647 new:2147483647
> slot: 00:09.0   old:2147483647 new:2147483647
> slot: 00:0a.0   old:2147483647 new:2147483647
> slot: 00:0d.0   old:2147483647 new:2147483647
> slot: 00:0d.1   old:2147483647 new:2147483647
> slot: 00:0d.2   old:2147483647 new:2147483647
> slot: 00:0d.3   old:2147483647 new:2147483647
> slot: 00:0d.4   old:2147483647 new:2147483647
> slot: 00:0d.5   old:2147483647 new:2147483647
> slot: 00:0d.6   old:2147483647 new:2147483647
> slot: 00:0e.0   old:2147483647 new:2147483647
> slot: 00:0e.1   old:2147483647 new:2147483647
> slot: 00:0e.2   old:2147483647 new:2147483647
> slot: 00:0e.3   old:2147483647 new:2147483647
> slot: 00:0e.4   old:2147483647 new:2147483647
> slot: 00:14.0   old:2147483647 new:2147483647
> slot: 00:14.1   old:2147483647 new:2147483647
> slot: 00:14.2   old:2147483647 new:2147483647
> slot: 00:1c.0   old:2147483647 new:2147483647
> slot: 03:00.0   old:0 new:0  **  net
> slot: 03:00.1   old:0 new:0  **  net
> slot: 00:1c.2   old:2147483647 new:2147483647
> slot: 04:00.0   old:0 new:0  **  net
> slot: 04:00.1   old:0 new:0  **  net
> slot: 00:1c.4   old:2147483647 new:2147483647
> slot: 02:00.0   old:2147483647 new:2147483647  **
> slot: 02:00.2   old:2147483647 new:2147483647  **
> slot: 02:00.4   old:2147483647 new:2147483647  **
> slot: 00:1d.0   old:2147483647 new:2147483647
> slot: 00:1d.1   old:2147483647 new:2147483647
> slot: 00:1d.2   old:2147483647 new:2147483647
> slot: 00:1d.3   old:2147483647 new:2147483647
> slot: 00:1d.7   old:2147483647 new:2147483647
> slot: 00:1e.0   old:2147483647 new:2147483647
> slot: 01:03.0   old:2147483647 new:2147483647  **
> slot: 00:1f.0   old:2147483647 new:2147483647
> slot: 01:03.0   old:2147483647 new:2147483647
> slot: 02:00.0   old:2147483647 new:2147483647
> slot: 02:00.2   old:2147483647 new:2147483647
> slot: 02:00.4   old:2147483647 new:2147483647
> slot: 03:00.0   old:0 new:0   net
> adding slot: 0
>  setting embedded index: 1
> slot: 03:00.1   old:0 new:0   net
> found slot: 0 1
>  setting embedded index: 2
> slot: 04:00.0   old:0 new:0   net
> found slot: 0 2
>  setting embedded index: 3
> slot: 04:00.1   old:0 new:0   net
> found slot: 0 3
>  setting embedded index: 4
> slot: 05:00.0   old:2147483647 new:2147483647
> slot: 08:00.0   old:1 new:1
> slot: 0b:00.0   old:2 new:2   net
> adding slot: 2
>  setting index_in_slot : 1
> slot: 0e:00.0   old:3 new:3   net
> adding slot: 3
>  setting index_in_slot : 1
> BIOS device: em1
> Kernel name: em1
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 2
> Driver: bnx2
> Driver version: 2.1.11
> Firmware version: bc 5.2.3 NCSI 2.0.12
> Bus Info: 0000:03:00.0
> PCI name      : 0000:03:00.0
> PCI Slot      : embedded
> Embedded Index: 1
> 
> BIOS device: em2
> Kernel name: em2
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 3
> Driver: bnx2
> Driver version: 2.1.11
> Firmware version: bc 5.2.3 NCSI 2.0.12
> Bus Info: 0000:03:00.1
> PCI name      : 0000:03:00.1
> PCI Slot      : embedded
> Embedded Index: 2
> 
> BIOS device: em3
> Kernel name: em3
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 4
> Driver: bnx2
> Driver version: 2.1.11
> Firmware version: bc 5.2.3
> Bus Info: 0000:04:00.0
> PCI name      : 0000:04:00.0
> PCI Slot      : embedded
> Embedded Index: 3
> 
> BIOS device: em4
> Kernel name: em4
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 5
> Driver: bnx2
> Driver version: 2.1.11
> Firmware version: bc 5.2.3
> Bus Info: 0000:04:00.1
> PCI name      : 0000:04:00.1
> PCI Slot      : embedded
> Embedded Index: 4
> 
> BIOS device: p2p1
> Kernel name: p2p1
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 6
> Driver: mlx4_en
> Driver version: 1.5.4.1 (March 2011)
> Firmware version: 2.9.1200
> Bus Info: 0000:0b:00.0
> PCI name      : 0000:0b:00.0
> PCI Slot      : 2
> SMBIOS Label: PCI-E Slot 2
> Index in slot: 1
> 
> BIOS device: p2p2
> Kernel name: p2p2
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 7
> Driver: mlx4_en
> Driver version: 1.5.4.1 (March 2011)
> Firmware version: 2.9.1200
> Bus Info: 0000:0b:00.0
> PCI name      : 0000:0b:00.0
> PCI Slot      : 2
> SMBIOS Label: PCI-E Slot 2
> Index in slot: 1
> 
> BIOS device: p3p1
> Kernel name: p3p1
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 8
> Driver: mlx4_en
> Driver version: 1.5.4.1 (March 2011)
> Firmware version: 2.9.1200
> Bus Info: 0000:0e:00.0
> PCI name      : 0000:0e:00.0
> PCI Slot      : 3
> SMBIOS Label: PCI-E Slot 3
> Index in slot: 1
> 
> BIOS device: p3p2
> Kernel name: eth3
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> ifIndex: 9
> Driver: mlx4_en
> Driver version: 1.5.4.1 (March 2011)
> Firmware version: 2.9.1200
> Bus Info: 0000:0e:00.0
> PCI name      : 0000:0e:00.0
> PCI Slot      : 3
> SMBIOS Label: PCI-E Slot 3
> Index in slot: 1

From the output, it seems like the interface 'eth3' is getting an expected name 'p3p2', when 'biosdevname -d' is run from command line. But when system is rebooted the interface eth3 is not getting renamed to p3p2. 

One of the scenarios that could result in this is that there is an entry in '70-persistent-net.rules' with 'ATTR{address}==' with that of eth3. But i guess the possibility of this scenario is already eliminated.

Comment 21 Narendra K 2012-05-31 13:46:42 UTC
The difference in output from comment #14 and #19 seems to be:

The output in comment #14 shows that the 'BIOS device' has no name suggested.

BIOS device:
Kernel name: eth3
Permanent MAC: XX:XX:XX:XX:XX:XX
Assigned MAC : XX:XX:XX:XX:XX:XX
Driver: mlx4_en
Driver version: 1.5.4.1 (March 2011)
Firmware version: 2.8.600
Bus Info: 0000:0e:00.0

comment #19 shows the 'BIOS device' as 

> BIOS device: p3p2
> Kernel name: eth3


It could be that the system still has a '70-persistent-net.rules' file ?

Comment 22 Harald Hoyer 2012-06-04 08:22:19 UTC
(In reply to comment #21)
> The difference in output from comment #14 and #19 seems to be:
> 
> The output in comment #14 shows that the 'BIOS device' has no name suggested.
> 
> BIOS device:
> Kernel name: eth3
> Permanent MAC: XX:XX:XX:XX:XX:XX
> Assigned MAC : XX:XX:XX:XX:XX:XX
> Driver: mlx4_en
> Driver version: 1.5.4.1 (March 2011)
> Firmware version: 2.8.600
> Bus Info: 0000:0e:00.0
> 
> comment #19 shows the 'BIOS device' as 
> 
> > BIOS device: p3p2
> > Kernel name: eth3
> 
> 
> It could be that the system still has a '70-persistent-net.rules' file ?

yeah, I was suspecting that, too... But I explitcitly advised the tester to remove that rules file and all ifcfg-* which could carry HWADDR.

Will ask again.

Comment 24 jordan hargrave 2012-06-07 21:23:28 UTC
Created attachment 590302 [details]
new test case biosdevname

see if this makes the bios name appear properly

Comment 25 Robert Kennedy 2012-06-08 15:11:51 UTC
With the biosdevname from Comment #24:

Mellanox ConnectX-2 VPI card (currently set with one port as IB and one port as ethernet) now shows up as p2p0 - I didn't think biosdevname was into the 0-based numbering scheme.

Mellanox ConnectX-3 VPI card shows up as p2p1 (also set with one IB, one ethernet).

Chelsio T3 shows up correctly.

Chelsio T4 testing in unpossible at the moment.

Comment 26 jordan hargrave 2012-06-08 17:26:18 UTC
Hmm, p2p0 is still wrong :( not sure what is wrong.  Thanks for the help.  Do you have lspci -vvvvxxxx/biosdevname/biosdecode/dmidecode dumps for the X2 card?

Comment 27 Robert Kennedy 2012-06-08 17:42:46 UTC
The last set of attachments should still be valid for lspci and dmidecode:

https://bugzilla.redhat.com/attachment.cgi?id=584350

Comment 28 jordan hargrave 2012-06-11 21:30:18 UTC
Created attachment 591029 [details]
new test biosdevname x2

Comment 29 jordan hargrave 2012-06-14 19:41:55 UTC
Robert, can you test that latest biosdevname test I uploaded on Monday?

Comment 30 Robert Kennedy 2012-06-14 19:55:09 UTC
Jordan -

Mellanox ConnectX-2 VPI card shows up as p2p1 (correct AFAIK)
Mellanox ConnectX-3 VPI card shows up as p2p1 (correct AFAIK)
Both were set with ib, eth for their port configs.

Chelsio T3 shows up correctly (p1p1 and p1p2).
Chelsio T4 testing still not possible.

When we finish up some other testing I can flip the bits on the Mellanox port configs and see what happens with eth, eth.

Comment 31 Narendra K 2012-07-17 17:54:50 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > The difference in output from comment #14 and #19 seems to be:
> > 
> > The output in comment #14 shows that the 'BIOS device' has no name suggested.
> > 
> > BIOS device:
> > Kernel name: eth3
> > Permanent MAC: XX:XX:XX:XX:XX:XX
> > Assigned MAC : XX:XX:XX:XX:XX:XX
> > Driver: mlx4_en
> > Driver version: 1.5.4.1 (March 2011)
> > Firmware version: 2.8.600
> > Bus Info: 0000:0e:00.0
> > 
> > comment #19 shows the 'BIOS device' as 
> > 
> > > BIOS device: p3p2
> > > Kernel name: eth3
> > 
> > 
> > It could be that the system still has a '70-persistent-net.rules' file ?
> 
> yeah, I was suspecting that, too... But I explitcitly advised the tester to
> remove that rules file and all ifcfg-* which could carry HWADDR.
> 
> Will ask again.

Hi Harald,

Did you get a chance to rule out '70-persistent-net.rules' and 'ifcfg-*' files ?

Comment 32 Fedora Update System 2012-07-18 13:36:08 UTC
biosdevname-0.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/biosdevname-0.4.1-1.fc17

Comment 33 Fedora Update System 2012-07-19 09:02:09 UTC
Package biosdevname-0.4.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing biosdevname-0.4.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10778/biosdevname-0.4.1-1.fc17
then log in and leave karma (feedback).

Comment 34 Fedora Update System 2012-07-26 22:32:36 UTC
biosdevname-0.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.