Bug 816543 - SELinux update prevents system with ZFS root from booting
SELinux update prevents system with ZFS root from booting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 07:05 EDT by Marius Bjørnstad
Modified: 2012-06-22 09:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 09:25:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Bjørnstad 2012-04-26 07:05:47 EDT
Description of problem: System hangs during boot. Very little relevant debug information is available. After a few minutes, messages like this appear:
udevd[nnnn]: timeout: killing 'xxxx'
There are many commands for 'xxxx', including 'udisks-part-id', 'alsactl' and more. 


Version-Release number of selected component (if applicable): 
ZFS on Linux 0.6.0-rc8.
I'll consider it OK to post a bug about ZFS, because the update text specifically mentions ZFS.


How reproducible: Always.    


Steps to Reproduce:
1. Encountered problem in normal update.
2. Rolled back system partition (after a day of troubleshooting), applied all updates but the selinux ones, and everyting OK.
3. Re-applied SElinux updates, and it failed again.

[ Update URL:
https://admin.fedoraproject.org/updates/FEDORA-2012-6385/selinux-policy-3.10.0-84.fc16?_csrf_token=ab56f70da1790147b63b4d77347d9a3dc8aa17b8 ] 

Actual results: Failure to boot. Can access complete system in Dracut shell if specifying wrong root device. No emergency shell in normal boot, system hangs.


Expected results: 


Additional info:
Comment 1 Miroslav Grepl 2012-04-26 07:21:28 EDT
Try to boot with

enforcing=0

as kernel parameter.
Comment 2 Marius Bjørnstad 2012-04-26 10:49:25 EDT
This indeed removed the problem. It's a good solution for me, because I'm not using enforing mode anyway.

Thanks,
Marius
Comment 3 Daniel Walsh 2012-04-26 11:26:03 EDT
We just added support for zfs to support XAttrs in F17.  Not sure if this is in F16.
Comment 4 Marius Bjørnstad 2012-04-26 13:43:35 EDT
Sorry, I got confused about whether I had applied the update. The enforce=0 parameter didn't actually fix the problem, but it's OK to wait for F17 before I apply the update.

Note You need to log in before you can comment on or make changes to this bug.