Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 816563 - [OSS] getting start or libra server in rhc client's config file need to updated in fedora image.
Summary: [OSS] getting start or libra server in rhc client's config file need to updat...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Pod
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Krishna Raman
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-26 12:14 UTC by Johnny Liu
Modified: 2015-05-15 01:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-13 23:44:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Johnny Liu 2012-04-26 12:14:46 UTC
Description of problem:
In rhc client's config file of fedora image, the libra server is "openshift.redhat.com" by default, and in the getting start html, it does not told user to change libra server of config file. 
If user is not familial with rhc, all operations will fail due to "Invalid user credentials".

It is better to modify default libra server in rhc config file or notice user in getting start html, that will improve user experience.

Version-Release number of selected component (if applicable):
openshift_origin.iso	26-Apr-2012

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Johnny Liu 2012-06-29 10:11:09 UTC
Verified this bug on latest fedora ISO image (MD5: cd573cfaace07e7949bc0c46028904ff), and PASS.

[liveuser@broker ~]$ cat .openshift/express.conf 
# SSH key file
#ssh_key_file = 'libra_id_rsa'
libra_server=localhost
# Default rhlogin to use if none is specified
default_rhlogin=admin

[liveuser@broker ~]$ rhc-domain-info -p admin
Application Info
================
No applications found.  You can use rhc-create-app to create new applications.


Note You need to log in before you can comment on or make changes to this bug.