Bug 816570 - Wrong path to munin jar in jmx plugin
Wrong path to munin jar in jmx plugin
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: munin (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 08:35 EDT by Ingvar Hagelund
Modified: 2012-05-26 03:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: munin-1.4.7-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-12 15:54:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingvar Hagelund 2012-04-26 08:35:24 EDT
Description of problem:
Wrong path to munin jar in jmx plugin

Version-Release number of selected component (if applicable):
munin-node-1.4.7-1.el5 (and probably all recent munin-node packages in fedora)

How reproducible:
Always

Steps to Reproduce:
1. install munin-node. 
2. Configure and activate the jmx plugin
3. Test a plugin, like munin-run jmx_Uptime
  
Actual results:
Java stack trace because munin jar is not found

Expected results:
jmx output

Additional info:
The plugin has hardcoded wrong path to the munin jar. I can't remember if this is a configurable done by make install, or it has to be edited by hand (or script).

Trivial fix

yum install munin-java-plugins
sed -i 's,/opt/munin/lib/munin-jmx-plugins.jar,/usr/share/java/munin-jmx-plugins.jar,g' /usr/share/munin/plugins/jmx_

And btw, please consider moving the jmx_ plugin to munin-plugins-java. It won't work without that package, so bundling it with munin-node doesn't make sense.

And yet another btw, I think a better name on separate plugin packages should be munin-plugins-jmx, munin-plugins-foo, munin-plugins-bar, etc, like the convention used in the nagios plugins packages.

Ingvar
Comment 1 Kevin Fenzi 2012-04-27 10:56:36 EDT
Thanks for the note. I am sure I fixed this before, but it seems to be back. ;(

Can you test: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=4028979

and let me know if it looks correct? If so, I can push an update...
Comment 2 Fedora Update System 2012-04-27 12:29:18 EDT
munin-1.4.7-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-1.4.7-3.fc17
Comment 3 Fedora Update System 2012-04-27 12:42:44 EDT
munin-1.4.7-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/munin-1.4.7-3.fc16
Comment 4 Fedora Update System 2012-04-27 12:58:33 EDT
munin-1.4.7-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/munin-1.4.7-3.fc15
Comment 5 Fedora Update System 2012-04-27 13:14:02 EDT
munin-1.4.7-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-1.4.7-3.el6
Comment 6 Fedora Update System 2012-04-27 13:23:13 EDT
munin-1.4.7-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-1.4.7-3.el5
Comment 7 Fedora Update System 2012-04-27 19:08:59 EDT
Package munin-1.4.7-3.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing munin-1.4.7-3.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5721/munin-1.4.7-3.el5
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-05-12 15:54:41 EDT
munin-1.4.7-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-05-12 15:55:26 EDT
munin-1.4.7-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-05-12 21:51:43 EDT
munin-1.4.7-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-05-12 21:57:26 EDT
munin-1.4.7-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-05-26 03:38:58 EDT
munin-1.4.7-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.