Bug 816613 - ValueError: not enough space in VG
ValueError: not enough space in VG
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f7d9904d1854564c9eca0be5362...
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-04-26 09:58 EDT by Clyde E. Kunkel
Modified: 2012-04-28 14:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-28 14:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-uINMR5 (2.27 MB, text/plain)
2012-04-26 09:58 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2012-04-26 09:58:48 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-uINMR5
hashmarkername: anaconda
kernel:         3.3.2-8.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Thu 26 Apr 2012 05:56:56 AM EDT
version:        17-TC1

anaconda-tb-uINMR5: Binary file, 2375930 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.22 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 54, in getTempVG
:    raise ValueError("not enough space in VG")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 69, in computeSpaceValues
:    vg = self.getTempVG()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 965, in updateVGSpaceLabels
:    (total, used, free, snapshots, reserved) = self.computeSpaceValues()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 1580, in __init__
:    self.updateVGSpaceLabels()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1777, in editLVMLogicalVolume
:    lv.vg, isNew = False)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1668, in editCB
:    self.editLVMLogicalVolume(lv = device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1195, in treeActivateCB
:    self.editCB()
:ValueError: not enough space in VG

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.Afwrdk
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:TZ=America/New_York
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Clyde E. Kunkel 2012-04-26 09:58:56 EDT
Created attachment 580486 [details]
File: anaconda-tb-uINMR5
Comment 2 Clyde E. Kunkel 2012-04-26 10:24:46 EDT
This is a regression.

Double clicking an LV or clicking the edit button to create / causes this error.  The VG is full, so reusing an existing LV is the way I installed F17 thru alpha and beta using the DVD iso.

I believe this should also block final.
Comment 3 Tim Flink 2012-04-26 13:18:24 EDT
I see anaconda 17.22 in the tb - I assume that means you did this test with F17 final TC1?

Just to make sure that I'm understanding the process for this crash:
 - boot DVD iso on system with full disks
 - start custom partition layout (not any of the autopart options)
 - double click lv that's in a full vg (which should pull up the "vg editing" 
   menu IIRC)
 - crash

Did I get that right?

If so, I'd say that this violates the following F17 final release criterion:
"The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above"

Unless this turns out to be an "unworkable partition layout", I'm +1 blocker
Comment 4 Clyde E. Kunkel 2012-04-26 18:49:22 EDT
(In reply to comment #3)
> I see anaconda 17.22 in the tb - I assume that means you did this test with F17
> final TC1?
> 
> Just to make sure that I'm understanding the process for this crash:
>  - boot DVD iso on system with full disks
>  - start custom partition layout (not any of the autopart options)
>  - double click lv that's in a full vg (which should pull up the "vg editing" 
>    menu IIRC)
>  - crash
> 
> Did I get that right?
> 

You got it right.  And, it is F17 final TC1.  Also, note that this is a regression in that the identical method worked without error with F17 beta.
Comment 5 Clyde E. Kunkel 2012-04-28 14:23:13 EDT
fixed in anaconda-17.23-1.fc17.  Closing

Note You need to log in before you can comment on or make changes to this bug.