Bug 816616 - group members are now lowercased in case insensitive domains
group members are now lowercased in case insensitive domains
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.3
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 10:04 EDT by Jakub Hrozek
Modified: 2012-06-20 07:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: sssd-1.8.0-25.el6
Doc Type: Bug Fix
Doc Text:
No documentation required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2012-04-26 10:04:42 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/1312

Group member names are returned as-is even if a domain is case-insensitive. We need to filter the name through sss_get_cased_name() before returning it.
Comment 4 Kaushik Banerjee 2012-05-02 14:42:38 EDT
Verified in version sssd-1.8.0-25


Output of beaker automation run:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: case_sensitive11: case_sensitive=false lookup user, group and netgroup
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

uid=1111111(user_cs1) gid=1111111(user_cs1_grp1) groups=1111111(user_cs1_grp1)
:: [   PASS   ] :: Running 'id user_cs1 | grep user_cs1_grp1'
uid=1111111(user_cs1) gid=1111111(user_cs1_grp1) groups=1111111(user_cs1_grp1)
:: [   PASS   ] :: Running 'id USER_CS1_Alias | grep user_cs1_grp1'
user_cs1
:: [   PASS   ] :: Running 'getent passwd User_CS1 | awk -F: '{print $1}' | grep user_cs1'
user_cs1
:: [   PASS   ] :: Running 'getent passwd user_cS1 | awk -F: '{print $1}' | grep user_cs1'
user_cs1
:: [   PASS   ] :: Running 'getent passwd user_cs1_alias | awk -F: '{print $1}' | grep user_cs1'
user_cs1_grp1
:: [   PASS   ] :: Running 'getent group USER_CS1_GRP1 | awk -F: '{print $1}' | grep user_cs1_grp1'
user_cs1
:: [   PASS   ] :: Running 'getent group user_cs1_grp1 | awk -F: '{print $4}' | grep user_cs1'
user_cs1_grp1:*:1111111:user_cs1
:: [   PASS   ] :: Running 'getent group user_cs1_grp1_alias'
user_cs1_grp1
:: [   PASS   ] :: Running 'getent group USER_CS1_GRP1_ALIAS | awk -F: '{print $1}' | grep user_cs1_grp1'
user_cs1
:: [   PASS   ] :: Running 'getent group user_cs1_grp1_alias | awk -F: '{print $4}' | grep user_cs1'
'8fb4eca5-d113-4fbc-8e2f-a329bdaa1076'
case-sensitive11 result: PASS

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: case_sensitive12: rfc2307bis case_sensitive=false lookup user, group and netgroup
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

uid=1111112(user_cs2) gid=1111112(user_cs2_grp1) groups=1111112(user_cs2_grp1)
:: [   PASS   ] :: Running 'id user_cs2 | grep user_cs2_grp1'
uid=1111112(user_cs2) gid=1111112(user_cs2_grp1) groups=1111112(user_cs2_grp1)
:: [   PASS   ] :: Running 'id USER_CS2_ALIAS | grep user_cs2_grp1'
user_cs2
:: [   PASS   ] :: Running 'getent passwd User_CS2 | awk -F: '{print $1}' | grep user_cs2'
user_cs2
:: [   PASS   ] :: Running 'getent passwd USEr_CS2 | awk -F: '{print $1}' | grep user_cs2'
user_cs2
:: [   PASS   ] :: Running 'getent passwd USER_CS2_AliaS | awk -F: '{print $1}' | grep user_cs2'
user_cs2
:: [   PASS   ] :: Running 'getent passwd user_cs2_alias | awk -F: '{print $1}' | grep user_cs2'
user_cs2_grp1
:: [   PASS   ] :: Running 'getent group USER_CS2_grp1 | awk -F: '{print $1}' | grep user_cs2_grp1'
user_cs2
:: [   PASS   ] :: Running 'getent group user_cs2_grp1 | awk -F: '{print $4}' | grep user_cs2'
user_cs2_grp1
:: [   PASS   ] :: Running 'getent group User_CS2_GRP1_ALIAS | awk -F: '{print $1}' | grep user_cs2_grp1'
user_cs2
:: [   PASS   ] :: Running 'getent group user_cs2_grp1_alias | awk -F: '{print $4}' | grep user_cs2'
'51efb8b4-9dc4-4136-9b7c-4d6c964d4a4f'
case-sensitive12 result: PASS
Comment 5 Stephen Gallagher 2012-06-12 09:04:51 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation required
Comment 7 errata-xmlrpc 2012-06-20 07:56:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.