Bug 81662 - (NET E100)eth0 remains down after reboot on Compaq "en small"
(NET E100)eth0 remains down after reboot on Compaq "en small"
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-12 06:48 EST by Andre Mueller
Modified: 2013-07-02 22:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (8.59 KB, text/plain)
2003-01-12 07:07 EST, Andre Mueller
no flags Details

  None (edit)
Description Andre Mueller 2003-01-12 06:48:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
Hello 

Before reporting to redhat bug report the problem was approached in detail in
the redhat support area (see Service Request 224318).

I was running redhat linux 6.1 to 7.3 on a Compaq en small pc-computer as
monitor less server without any problem described as in the following. 

Since I upgraded to redhat linux 8.0 these days on reboot the ethernet interface
eth0 is switched off at shutdown time but is not switched on again on boot time
even in the boot message bringing up eth0 is reported as ok. There is no way to
prevent linux 8.0 to shutdown completely the eth0 interface at shutdown -h and
-r time. After a regular Linux shutdown the yellow LED for activation (green LED
for traffic) on the eth0 RJ45 connector remains off until pulling out and
replug-in the power cord of the pc. Switching on/off by the power switch has
only a positive effect to eth0, if the computer had first pulled off the power
cord and switching on/off occurs during self test e.g. the bios screen interval. 
Issuing during normal operation the command "ifdown eth0" and there after "ifup
eth0" has the same effect; eth0 remains switched off. The same is true to a
network restart -> "service network restart". Disabling the command ifdown in
the shutdown operation sequence delays the eth0 switch off, but it occurs at all
the same at the very end of the shutdown operation.


In accordance with the suggestion of redhat support, I tried to apply different
parameters to kernel command: I have tried first to apply the noapic parameter
to the boot command as suggest from redhat support. It had no influence to the
behavior of linux on boot time - apic was enabled by linux again and it has no
influence at all to my  problem with the shuted down eth0 interface. So I tried
without success to apply all possible amp parameters (one on each test) to the
boot command. Even I tried the same apm parameters in combination with turned
on/off apm in the bios. I guess there is some change in redhat 8.0 since 7.3
concerning bringing down eth interfaces that interfere with the advanced power
management on wake up LAN functionality of the compaq en small pc even if they
are switched off in the bios.

Many thanks in advance and best regards

Andr� M�ller


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
- command reboot or shutdown -r or shutdown -h
- or command "ifdown eth0" and there after "ifup eth0"
- or command "service network restart"

    

Actual Results:  eth0 remains switched of after reboot

Expected Results:  eth0 is switched on or remains switched on after a reboot

Additional info:
Comment 1 Andre Mueller 2003-01-12 07:07:05 EST
Created attachment 89319 [details]
dmesg log
Comment 2 Arjan van de Ven 2003-01-12 07:18:34 EST
it seems you're using the eepro100 driver. There is also an alternate driver for
the same hardware, called e100. Both drivers work for most people, but for some
people eepro100 works better, while for other e100 works better. Could you try
the e100 driver? You can change driver by editing the /etc/modules.conf file and
replacing "eepro100" with "e100".
Comment 3 Andre Mueller 2003-01-12 08:42:50 EST
Hello

Many thanks for your prompt response!

Your suggestion changed quite alot the behavior but did not resolve the problem,
a new one was created:

- I did the change in /etc/modules.conf file from eepro100 to e100 and shutdown
the system and switched of the power and pulled out the power cord.

Step 1:

- switched on the pc (yellow LED on eth0 is on)
- booted the system (yellow LED on eth0 is on)
- dmesg gives the following statment fragment:
- eth0 is working

PCI: Found IRQ 11 for device 00:0a.0
PCI: Sharing IRQ 11 with 00:14.2
divert: allocating divert_blk for eth0
e100: eth0: Compaq Fast Ethernet Server Adapter
  Mem:0x42000000  IRQ:11  Speed:100 Mbps  Dx:Half

Step 2:
- rebooting with the command "shutdown -r "now"
- eth0 is not switched off (yellow LED on eth0 remains on)
- on boot time eth0 is not recognized see dmesg fragemtn bellow (yellow LED on
eth0 is on):
- eth0 does not work (yellow LED on eth0 remains on)

PCI: Enabling device 00:0a.0 (0000 -> 0003)
PCI: Found IRQ 11 for device 00:0a.0
PCI: Sharing IRQ 11 with 00:14.2
PCI: Setting latency timer of device 00:0a.0 to 64
e100: selftest failed
e100: Failed to initialize, instance #0
Intel(R) PRO/100 Network Driver -version 2.1.6.-k1
Copyrigth (c) 2002 Intel Corporation

- issued the command "ifup eth0" and received the same messages lines as in the
dmesg fragment above.
- issued the cammand "service network restart" and received same messages lines
as in the dmesg fragment above.

Step 3.

- rebooted system by command "shutdown -r "now" (yellow LED on eth0 remains on)
- system goes down correctly (yellow LED on eth0 remains on)
- ->> new problem : system hangs infinitely after the prompt "Restarting
system"! (yellow LED on eth0 remains on)

----

I have reproduced this new "behavior" for test three times and also two times by
removing the kernel parameter amp=power_off in the /etc/grub.conf restarting on
Step 1. So step 1 to 3 can always be reproduced.

Many thanks in advance and with best regards, 

André Müller











Comment 4 Bugzilla owner 2004-09-30 11:40:23 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.