Bug 816632 - Torquebox: Messaging module depends on JMS 1.1, EAP6 ER5 and newer use JMS 1.2
Torquebox: Messaging module depends on JMS 1.1, EAP6 ER5 and newer use JMS 1.2
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TorqueBox (Show other bugs)
2.0.0.ER4
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0.0.ER7
Assigned To: Bob McWhirter
Oliver Kišš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 10:47 EDT by Oliver Kišš
Modified: 2015-08-02 19:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 07:27:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Kišš 2012-04-26 10:47:21 EDT
Description of problem:

Torquebox Messaging module in Torquebox 2.0.1 depends on JMS 1.1
EAP 6 uses JMS 1.2 since ER5


Version-Release number of selected component (if applicable):
Torquebox 2.0.1
Comment 1 Karel Piwko 2012-04-27 03:24:50 EDT
This renders project unusable with EAP ER5 and newer using EAP Maven repository zip.
Comment 2 Bob McWhirter 2012-05-01 10:04:18 EDT
We are unsure where this mismatch is coming from, as AS7 appears to still use JMS 1.1.

Any idea?
Comment 3 Bob McWhirter 2012-05-01 10:07:40 EDT
Additionally, i cannot find a JMS 1.2 spec jar in the .org Nexus maven repository:

https://repository.jboss.org/nexus/index.html#nexus-search;quick~jboss-jms-api
Comment 5 Oliver Kišš 2012-06-04 07:27:23 EDT
I am sorry for the confusion. I meant messaging subsystem, not JMS.

This is now fixed in Torquebox 2.0.3.redhat.1 which is based on newer versions of EAP.

Note You need to log in before you can comment on or make changes to this bug.