Bug 816640 - APC power management interface fails to pass parameters to underlying fence_apc
APC power management interface fails to pass parameters to underlying fence_apc
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eli Mesika
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 11:12 EDT by Ian Levesque
Modified: 2013-07-25 16:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 16:50:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Levesque 2012-04-26 11:12:33 EDT
Description of problem:

I'm trying to configure power management in order to enable the high availability feature of ovirt. Without proper fencing, it appears from my research that ovirt doesn't auto-migrate VMs from failed nodes, which is a prerequisite for using ovirt at our site. 

From a host's power management interface, I enter the IP, user/pass, "apc" as type, the port and slot, then check "secure". When I click "Test", I receive an error:

    Test Failed, Host Status is: unknown. The fence-agent script reported the following error: 
	Failed: You have to enter plug number Please use '-h' for usage

High-availability failover therefore isn't attempted.


Version-Release number of selected component (if applicable):

ovirt-engine-3.1.0_0001-1.8.el6.x86_64


How reproducible:


Steps to Reproduce:
1. add host in ovirt-engine web interface
2. in "power management", enable and fill in all fields for APC type
3. click test
  
Actual results:

    Error:
    Test Failed, Host Status is: unknown. The fence-agent script reported the following error: 
	Failed: You have to enter plug number Please use '-h' for usage


Expected results:

Host's power management effectively configured, thereby enabling ovirt's high-availability features.

Additional info:
Comment 1 Ian Levesque 2012-04-26 11:13:54 EDT
Here's the vdsm and engine log output when I click "Test":

------------------------------------------------------------
==> ../ovirt-engine/engine.log <==
2012-04-25 12:18:50,302 INFO  [org.ovirt.engine.core.bll.FencingExecutor] (http--0.0.0.0-8443-4) Executing <Status> Power Management command, Proxy Host:heilig, Agent:apc, Target Host:, Management IP:134.174.x.x, User:ovirt, Options:port=22,plug=1,secure=true,slot=1

2012-04-25 12:18:50,305 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (http--0.0.0.0-8443-4) START, FenceVdsVDSCommand(vdsId = 6de5e3fa-8a33-11e1-b3f9-003048c85226, targetVdsId = 60087c5e-8a3b-11e1-b15d-003048c85226, action = Status, ip = 134.174.x.x, port = , type = apc, user = ovirt, password = ******, options = 'port=22,plug=1,secure=true,slot=1'), log id: 56a240f9


==> vdsm.log <==
Thread-52872::DEBUG::2012-04-25 12:18:50,311::API::954::vds::(fenceNode) fenceNode(addr=134.174.x.x,port=,agent=apc,user=ovirt,passwd=XXXX,action=status,secure=,options=)
Thread-52872::DEBUG::2012-04-25 12:18:50,348::API::980::vds::(fenceNode) rc 1 in agent=fence_apc
ipaddr=134.174.x.x
login=ovirt
option=status
passwd=XXXX
 out  err Failed: You have to enter plug number
Please use '-h' for usage

Thread-52873::DEBUG::2012-04-25 12:18:50,356::API::954::vds::(fenceNode) fenceNode(addr=134.174.x.x,port=,agent=apc,user=ovirt,passwd=XXXX,action=status,secure=,options=)
Thread-52873::DEBUG::2012-04-25 12:18:50,392::API::980::vds::(fenceNode) rc 1 in agent=fence_apc
ipaddr=134.174.x.x
login=ovirt
option=status
passwd=XXXX
 out  err Failed: You have to enter plug number
Please use '-h' for usage
------------------------------------------------------------

See the thread in ovirt-users here:
http://lists.ovirt.org/pipermail/users/2012-April/001699.html
Comment 2 Yaniv Kaul 2012-04-27 04:12:34 EDT
Please specify the version of fence-agents package that is on the host (the one with VDSM on it).
Comment 3 Ian Levesque 2012-04-27 08:11:37 EDT
fence-agents-3.1.5-10.el6_2.2.x86_64
Comment 4 Ian Levesque 2012-07-19 15:22:04 EDT
Any updates on this? I can't setup a highly-available cluster of VM hosts until this apparently minor bug is resolved or I hear of a suitable workaround.
Comment 5 Eli Mesika 2013-02-16 16:52:37 EST
this was resolved by Roy Golan (vdsm bug)
probably requires vdsm upgrade 
Roy, please specify the version on which that was resolved
Comment 7 Eli Mesika 2013-02-20 09:26:09 EST
please check vdsm version and see if it is below  vdsm-4.9.6-29.0 
If it below  vdsm-4.9.6-29.0 , please close the bug as this was laready resolved
Comment 8 Eli Mesika 2013-04-06 15:49:32 EDT
BZ was resolved in vdsm-4.9.6-29.0 
Please note that for verification you should only check the vdsm.log abd see that all parameters are passed correctly.
Please also note that since our lab was upgraded to APC 5.x you will not be able to get it working (the workaround is to use apc_snmp agent) , however, as stated above only parameters passing verification is needed

Note You need to log in before you can comment on or make changes to this bug.