Bug 816663 - Enhancement request: sensord logging facility should be controllable through /etc/sysconfig
Enhancement request: sensord logging facility should be controllable through ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lm_sensors (Show other bugs)
6.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Martin Sehnoutka
William Gomeringer
: EasyFix, FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 12:10 EDT by Gianni Giardina
Modified: 2016-07-19 03:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 03:58:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch resolving the issue (646 bytes, patch)
2012-04-26 12:10 EDT, Gianni Giardina
no flags Details | Diff

  None (edit)
Description Gianni Giardina 2012-04-26 12:10:15 EDT
Created attachment 580518 [details]
Patch resolving the issue

* Description of problem:

It should be possible to select the syslog facility used by the sensord service through the /etc/sysconfig/sensord file. Even if it's trivial to modify the service's init script /etc/rc.d/init.d/sensord in order to change the used facility, those changes would be lost with the next package update. Nevertheless, it's very useful to be able to use a facility other than "daemon" when you need to handle log messages through /etc/rsyslog.conf.

I've attached a patch proposal resolving the issue.


* Version-Release number of selected component (if applicable):

lm_sensors-sensord-3.1.1-10


* How reproducible:

service sensord start

  
* Actual results:

/var/log/messages filled by sensor readings


* Expected results:

Being able to log sensor readings to a dedicated file, e.g /var/log/sensors, very hard without changing the syslog facility used by sensord.
Comment 2 RHEL Product and Program Management 2012-09-07 01:32:34 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Martin Sehnoutka 2016-07-19 03:58:46 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

Note You need to log in before you can comment on or make changes to this bug.