Bug 816680 - Child availability still up with down parent after shutdown operation on AS5
Child availability still up with down parent after shutdown operation on AS5
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent, Operations, Plugin Container (Show other bugs)
4.4
All All
urgent Severity high (vote)
: ---
: RHQ 4.4.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-04-26 12:37 EDT by Jay Shaughnessy
Modified: 2013-08-31 05:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 05:55:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2012-04-26 12:37:14 EDT
A possible regression because I'm fairly sure this was working. But I
just saw the following and it didn't seem environmental. I'll have to
check it out:

1) AS5 into inventory
2) Make sure it is running and showing GREEN avail
3) Shutdown via operation 
4) After successful shutdown wait between 30-60s for
   the requested lifecycle avail check to take place
   and report to the server.

The AS should show RED as should all of its children.

But I'm seeing a change only for the AS.
Comment 1 Jay Shaughnessy 2012-04-27 18:25:40 EDT
This looks like a real regression. Working it.
Comment 2 Jay Shaughnessy 2012-04-27 20:02:14 EDT
commit 26cbde9ab726fbf1c34e7e7f03f498e2530e72a3

    - remove some confusion between use of null and UNKNOWN
    - remove some confusion around NOT UP and DOWN
    - improve some logic around deferring to a parent's DOWN status
    - protect against invalid return values from AvailabilityFacet.getAvailability() impls


Test Notes:
In addition to the reproduction steps, try a start operation as well,
which brings resources UP as opposed to DOWN.  or anything else that
you can think of.
Comment 3 Sunil Kondkar 2012-04-30 07:16:13 EDT
Verified on build#1429 (Version: 4.4.0-SNAPSHOT Build Number: e566c0a)

Verified availability with stop and start operations. The AS resource and it's child resources are DOWN after stop operation and UP after start operation.
Also verified availability by stopping AS5 instance manually with <ctl C> and then starting manually again.

Note You need to log in before you can comment on or make changes to this bug.