Bug 816692 - /usr/lib64/freerdp/rdpsnd_pulse.so: undefined symbol: pa_threaded_mainloop_new
/usr/lib64/freerdp/rdpsnd_pulse.so: undefined symbol: pa_threaded_mainloop_new
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freerdp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mads Kiilerich
Fedora Extras Quality Assurance
:
: 817493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 13:37 EDT by Scott Tsai
Modified: 2012-09-24 07:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: freerdp-1.0.1-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 00:21:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2012-04-26 13:37:16 EDT
Description of problem:
/usr/lib64/freerdp/rdpsnd_pulse.so should be linked against libpulse.so.0 bust isn't. This is fixed upstream in:
https://github.com/FreeRDP/FreeRDP/issues/418
https://github.com/FreeRDP/FreeRDP/commit/c10866db66c0d462ea7c2c38bb01740bcfb4fcb4


Version-Release number of selected component (if applicable):
freerdp-1.0.1-5.fc17.x86_64
freerdp-plugins-1.0.1-5.fc17.x86_64

How reproducible:


Steps to Reproduce:
xfreerdp --plugin rdpsnd -g 1024x768 192.168.122.157 # The of my Windows XP Virtual Machine

  
Actual results:
Loading plugin rdpsnd
connected to 192.168.122.157:3389
xfreerdp: symbol lookup error: /usr/lib64/freerdp/rdpsnd_pulse.so: undefined symbol: pa_threaded_mainloop_new


Additional info:
I recommend just pulling in this single patch from upstream: https://github.com/FreeRDP/FreeRDP/commit/c10866db66c0d462ea7c2c38bb01740bcfb4fcb4
Comment 1 Mads Kiilerich 2012-04-26 19:19:48 EDT
Please try http://koji.fedoraproject.org/koji/taskinfo?taskID=4027320
Comment 2 Scott Tsai 2012-04-26 20:24:36 EDT
(In reply to comment #1)
> Please try http://koji.fedoraproject.org/koji/taskinfo?taskID=4027320

This build works great! ^_^
Thanks for the prompt response.
Comment 3 Mads Kiilerich 2012-04-30 05:39:18 EDT
*** Bug 817493 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-04-30 05:41:24 EDT
freerdp-1.0.1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/freerdp-1.0.1-6.fc17
Comment 5 Fedora Update System 2012-04-30 14:47:22 EDT
Package freerdp-1.0.1-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freerdp-1.0.1-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6934/freerdp-1.0.1-6.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-08 00:21:38 EDT
freerdp-1.0.1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 James Patterson 2012-09-24 07:49:06 EDT
Could we get this into EPEL6 too? It's still broken there. Thanks.

Note You need to log in before you can comment on or make changes to this bug.