Bug 816701 - Anaconda should not default to gpt on BIOS systems
Anaconda should not default to gpt on BIOS systems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 14:01 EDT by Matthew Garrett
Modified: 2013-01-10 02:53 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-17.24-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 12:04:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Garrett 2012-04-26 14:01:07 EDT
We already blacklist Lenovos because this breaks them - it seems that it breaks some Dells too (http://lists.us.dell.com/pipermail/linux-desktops/2012-April/003976.html). The boot flag workaround doesn't seem to be sufficient. Since we're unlikely to ever be sure that we've found the full set of broken machines, it's safer to revert back to using MBR on BIOS systems.
Comment 1 Brian Lane 2012-04-26 18:35:53 EDT
We should also add an inst.gpt option to force using GPT for those that want it.
Comment 2 Adam Williamson 2012-05-03 13:22:07 EDT
Discussed at 2012-05-03 blocker review meeting. We agreed this does not constitute a blocker, though it's a sensible change and will make the release: there's no clear evidence it breaks enough systems to constitute criteria breakage, and indeed if it were truly a blocker, we should be recalling Fedora 16...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.