Bug 816712 - Evolution keeps using 100% CPU
Evolution keeps using 100% CPU
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 15:02 EDT by gareth foster
Modified: 2012-06-28 02:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-data-server-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 02:33:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (33.30 KB, text/plain)
2012-04-28 12:39 EDT, gareth foster
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 664639 None None None Never

  None (edit)
Description gareth foster 2012-04-26 15:02:56 EDT
Description of problem:
I've found Evolution twice now using 100% CPU on my laptop, not sure what's casuing it.

Can I get a backtrace of what it's doing or something to help?
Comment 1 Milan Crha 2012-04-27 04:31:16 EDT
Thanks for a bug report. Yes, you can, backtrace will help to narrow what it is doing. First of all, please install debuginfo packages for gtkhtml3, evolution-data-server, evolution and any other evolution related packages you have installed and you use. Then run evolution and let it make the state with eating CPU. Open a terminal and get process ID of the currently running evolution. You can do that with command like this:
   $ ps ax | grep evolution
then invoke this command to get backtrace:
   $ gdb --batch --ex "t a a bt" -pid=PID &>bt.txt
where PID is a process ID of running evolution. There is one issue with the gdb in F17, the ptrace SELinux policy, thus please check the bt.txt file and if it'll include instructions how to disable that policy, then follow them.

Before you attach the backtrace, please make sure you'll not expose any private information, like passwords, server address or such. I usually search for "pass" (quotes for clarity only) in the backtrace, which spots 99% of password occurrences in it.
Comment 2 gareth foster 2012-04-28 12:39:23 EDT
Created attachment 580984 [details]
Backtrace

Here we are, as you asked.
Comment 3 gareth foster 2012-04-28 12:41:09 EDT
Btw, this seemed to happen after suspend, and switching to my girlfriend's desktop and back.
Comment 4 Milan Crha 2012-05-02 05:54:21 EDT
Thanks for the update. I see it's trying to disconnect your IMAPx account. There is missing all debug information, I think because your binary package version differs from the debuginfo package version (rpm -qa | grep evolution | sort), but it seems to me that it's just it.

I noticed exactly the same behaviour recently, when I was working on [1]. The fix from there fixed the issue for me.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=664639
Comment 5 gareth foster 2012-05-02 16:43:10 EDT
Is that patch going to be in F17?
Comment 6 Milan Crha 2012-05-03 02:41:08 EDT
(In reply to comment #5)
> Is that patch going to be in F17?

It's not committed for it currently. I can let it be part of 3.4.2, but I would appreciate if you could test it first. I built a test evolution-data-server package for this purpose here [1], thus if you could give it a try, then it'll be helpful. Thanks in advance.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=4048599
Comment 7 gareth foster 2012-05-03 13:12:50 EDT
Good stuff, I installed your RPM, let's see what it does. Ta duck.
Comment 8 gareth foster 2012-05-20 09:16:54 EDT
This RPM doesn't seem to be helping, Evolution is still unusable for me.
Comment 9 Milan Crha 2012-05-21 04:08:28 EDT
(In reply to comment #8)
> This RPM doesn't seem to be helping, Evolution is still unusable for me.

Was it all the time, since 2012-05-03, or it did it again just recently? I'm asking because there happened a release of evolution last week, 3.4.2, which doesn't have that fix included.
Comment 10 gareth foster 2012-05-21 11:41:46 EDT
evolution-data-server-3.4.1-2.fc17.x86_64
evolution-data-server-debuginfo-3.4.1-1.fc17.x86_64
evolution-NetworkManager-3.4.1-2.fc17.x86_64
evolution-help-3.4.1-2.fc17.noarch
evolution-debuginfo-3.4.1-1.fc17.x86_64
evolution-3.4.1-2.fc17.x86_64

That looks rather like YUM has removed the fix for me then?
Comment 11 Milan Crha 2012-05-21 13:02:40 EDT
Oh, it does remove it, because of newer
  3.4.1-2, with compare of test package
  3.4.1-1.1
You can see when it happened:
   $ cat /var/log/yum.log | grep evolution | grep 3.4.1-2
Comment 12 gareth foster 2012-05-21 16:42:18 EDT
Balls. I tried to download the fixed one again, but that RPM build page is impossible to find an actual RPM on. Where do I look?
Comment 13 Milan Crha 2012-05-22 06:38:08 EDT
Right, it was just a scratch build, and as such it is automatically vanished after few days. I made a new scratch build for you:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4093667
Comment 14 gareth foster 2012-05-22 06:58:36 EDT
Oh wow, thanks mate. Installed, hopefully that'll fix it, and your patch will get to the next release!
Comment 15 Milan Crha 2012-05-23 02:54:25 EDT
Please let me know in a week or two, thus I'll know whether I can commit it or not for stable (thinking of it, there was a followup commit which I didn't include in this package, though it might not be a problem, I believe).
Comment 16 gareth foster 2012-06-27 17:18:42 EDT
Seems better now, commit away!
Comment 17 Milan Crha 2012-06-28 02:33:39 EDT
Thanks. It is part of eds 3.4.3. I forgot about this bug and didn't update it. I'm sorry.

Note You need to log in before you can comment on or make changes to this bug.