Bug 816765 - please merge 'fr_FR' transifex team under 'fr'
please merge 'fr_FR' transifex team under 'fr'
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: installation-quick-start-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Jack Reed
Fedora Docs QA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 18:29 EDT by Kevin Raymond
Modified: 2013-06-17 01:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-26 13:45:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Raymond 2012-04-26 18:29:41 EDT
Once again, please merge the'fr_FR' transifex team under 'fr'.
And then delete the fr_FR one.

Would be appreciated to propagate this on all guides 


This should have been done for… F15 (at least).

Thanks.

see
https://fedora.transifex.net/projects/p/fedora/language/fr/?project=2180
https://fedora.transifex.net/projects/p/fedora/language/fr_FR/?project=2180
Comment 1 Petr Kovar 2012-05-14 14:44:19 EDT
Note that this doesn't only affect "fr" but also other teams with duplicated lang codes. They are all listed here:

https://fedora.transifex.net/projects/p/fedora-ins-quick-start-guide/

The solution here is to tx pull all PO files with duplicated XY_RS lang codes, fix the language map configuration in your .tx/config file [1], then copy the XY_RS PO files over the correct XY lang code PO files, and tx pull them to Transifex.

Finally, delete the old XY_RS PO files in your git repo and Transifex (with tx delete).

I'll be more than happy to assist whoever will be working on resolving this issue, feel free to ping me on #docs.

[1]
https://fedoraproject.org/wiki/Setting_up_a_document_with_Transifex#Step_5:_Map_Language_Codes
Comment 2 Kevin Raymond 2012-05-18 06:47:35 EDT
I tried, but I couldn't get it working because of push access.

The complete list, at least for the fr_FR language code, is:

fedora-accessibility-guide
fedora-docsite-publican
fedora-install-guide
fedora-readme-burning-isos
fedora-virtualization-guide
translation-quick-start-guide
Comment 3 Damien Gourbiere 2012-06-02 03:53:03 EDT
Hello,
I started translating the "Fedora installation Quick Start guide" document on transifex into French (fr) when I noticed that there were already translations for fr_FR.
I translated 4 items and I am upset that I did all this work for nothing :(

I'm now waiting for the merge to occur before I translate anything more on transifex.

Could you please look into this issue (for all files listed in comment 2 and all languages as well)? We REALLY would like to help to resolve this, is there anything we can do?
Comment 4 Jack Reed 2012-06-20 23:40:09 EDT
Hi Damien,

I've just discovered this bug and I'm so sorry to hear you spent this time fruitlessly. I can understand your frustration.

We have been having long-running problems with the Installation Guide and Installation Quick Start Guide on Transifex to the point where we have decided to move translation over to Zanata.

I am in the process of solving this now and will update this bug and post to translist when translation can commence.
Comment 5 Kevin Raymond 2013-03-26 13:45:10 EDT
I merged what needed to be yesterday, and remove the old language code at Transifex.

Note You need to log in before you can comment on or make changes to this bug.