Bug 816784 - Wifi driver doesn't start at pc boot
Summary: Wifi driver doesn't start at pc boot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-27 01:44 UTC by Matthieu Saulnier
Modified: 2012-06-09 17:19 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-09 17:19:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Matthieu Saulnier 2012-04-27 01:44:38 UTC
Description of problem:
When you turn on a pc using a wireless connection only, NetworkManager say wifi is unavailable.


Version-Release number of selected component (if applicable):
kernel 3.3.2-8.fc17.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Turn on a pc using wifi connection only
2. NM applet show you're not connected on any network
3. Clic on NM applet, NM inform you that wireless network is unavailable

How to Fix Temporarily:
1. Turn off and turn on the wifi card by the hard button
OR:
1. root@localhost# rmmod ath9k mac80211 ath9k_common ath9k_hw ath cfg80211
2. root@localhost# modprobe ath9k

After reboot, to do this procedure is needed again


Actual results:
Wifi doesn't work at boot

Expected results:
Wifi works at boot

Additional info:
$ lspci
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Comment 1 John W. Linville 2012-04-27 13:26:56 UTC
Sounds like rfkill status is not properly reported at driver startup...

Comment 2 antonio montagnani 2012-04-28 16:45:53 UTC
same here on iwl3945

Comment 3 Killian 2012-04-30 05:31:49 UTC
I have the same problem:
$ lspci
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

Comment 4 John W. Linville 2012-04-30 13:59:43 UTC
Three similar reports, different drivers.  This smells like a BIOS setup issue...

Please check your BIOS settings for options related to enabling/disabling wireless at bootup and the like.  Many laptops have configuration "features" that have caused similar issues in the past.

Comment 5 antonio montagnani 2012-04-30 14:15:12 UTC
the same laptop with F16 had no trouble at all, so I think that it is not connected to Bios.No issues also with Windows that had been blown away by Fedora :-)

I will check anyway

Comment 6 Mohammed Shafi 2012-04-30 14:19:56 UTC
http://linuxwireless.org/en/users/Documentation/rfkill

rfkill list will give some idea whether its soft blocked by defualt

Comment 7 antonio montagnani 2012-04-30 14:47:56 UTC
rfkill list
0: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Comment 8 antonio montagnani 2012-04-30 14:58:53 UTC
I note that all ifcfg files that were stored in /etc/sysconfig/networking/devices are now stored directly in /etc and no ifcfg-wlan0 is present.

Is it correct??

Comment 9 antonio montagnani 2012-04-30 16:03:54 UTC
another clue...


When I try to switch off the card by hardware, immediately it is re-activated!!
That is not true at boot-time

Comment 10 Matthieu Saulnier 2012-04-30 16:33:47 UTC
Just after boot:
 [casper@blackbird ~]$ rfkill list
 0: phy0: Wireless LAN
	 Soft blocked: no
	 Hard blocked: no
 1: hci0: Bluetooth
	 Soft blocked: no
	 Hard blocked: no

After fix:
 [casper@blackbird ~]$ rfkill list
 0: phy0: Wireless LAN
	 Soft blocked: no
	 Hard blocked: no
 2: hci0: Bluetooth
	 Soft blocked: no
	 Hard blocked: no

There is no changes with kernel-3.3.4-1.fc17.x86_64 too.

Comment 11 troilimathieu 2012-04-30 20:01:14 UTC
0: sony-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: sony-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

When I try to switch off the card by hardware, immediately it is re-activated!!


lspci

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc NI Whistler [AMD Radeon HD 6600M Series]
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5209 (rev 01)
04:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Comment 12 Matthieu Saulnier 2012-05-16 23:56:05 UTC
Seems to be fixed here.

Comment 13 Matthieu Saulnier 2012-06-09 17:19:08 UTC
Fixed since F17 RC2 release


Note You need to log in before you can comment on or make changes to this bug.